summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 09:26:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 09:31:55 +0200
commit845385ff3b420207f02fe9a266e7b85d136d2900 (patch)
tree55d8c74336ce7a3c79724f55721fecb0a141a507 /dev-python/babelfish/babelfish-9999.ebuild
parentdev-python/rebulk: Enable py3.11 (diff)
downloadgentoo-845385ff3b420207f02fe9a266e7b85d136d2900.tar.gz
gentoo-845385ff3b420207f02fe9a266e7b85d136d2900.tar.bz2
gentoo-845385ff3b420207f02fe9a266e7b85d136d2900.zip
dev-python/babelfish: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/babelfish/babelfish-9999.ebuild')
-rw-r--r--dev-python/babelfish/babelfish-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/babelfish/babelfish-9999.ebuild b/dev-python/babelfish/babelfish-9999.ebuild
index 8876693501c0..a4a6de6e16c4 100644
--- a/dev-python/babelfish/babelfish-9999.ebuild
+++ b/dev-python/babelfish/babelfish-9999.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 git-r3
DESCRIPTION="Python library to work with countries and languages"
-HOMEPAGE="https://github.com/Diaoul/babelfish https://pypi.org/project/babelfish/"
-EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
+HOMEPAGE="
+ https://github.com/Diaoul/babelfish/
+ https://pypi.org/project/babelfish/
+"
+EGIT_REPO_URI="https://github.com/Diaoul/babelfish.git"
LICENSE="BSD"
SLOT="0"
-BDEPEND="
- >=dev-python/pyproject2setuppy-20[${PYTHON_USEDEP}]"
-
distutils_enable_tests pytest