summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-06 19:34:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-06 20:00:04 +0300
commit2984c7dd763da5b15f244ab4dc332b4690561245 (patch)
tree04840d20f0eb4523c6c42a8512db51ec02d29da4 /dev-python/bashate/bashate-2.1.1.ebuild
parentwww-client/chromium-bin: add 106.0.5249.103 (diff)
downloadgentoo-2984c7dd763da5b15f244ab4dc332b4690561245.tar.gz
gentoo-2984c7dd763da5b15f244ab4dc332b4690561245.tar.bz2
gentoo-2984c7dd763da5b15f244ab4dc332b4690561245.zip
dev-python/bashate: add 2.1.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bashate/bashate-2.1.1.ebuild')
-rw-r--r--dev-python/bashate/bashate-2.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/bashate/bashate-2.1.1.ebuild b/dev-python/bashate/bashate-2.1.1.ebuild
new file mode 100644
index 000000000000..cd0df55538ec
--- /dev/null
+++ b/dev-python/bashate/bashate-2.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest