summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-07 06:13:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-07 06:43:04 +0200
commit2b95ab047caefe0cbb6467e7aa70b125e41b3612 (patch)
treef97bb67034b2669b6715d6ed56aa40ee8fe3800d /dev-python/bleach
parentdev-python/annotated-types: Bump to 0.6.0 (diff)
downloadgentoo-2b95ab047caefe0cbb6467e7aa70b125e41b3612.tar.gz
gentoo-2b95ab047caefe0cbb6467e7aa70b125e41b3612.tar.bz2
gentoo-2b95ab047caefe0cbb6467e7aa70b125e41b3612.zip
dev-python/bleach: Bump to 6.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-6.1.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 75f60ce26c2b..b9b0cf7dd336 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-6.0.0.tar.gz 201298 BLAKE2B e4af5da351fdb63bc75b935f70f40434bd81c49cde4f584901397e5fd4ac4507d2e29eb283ff28a764018dbd795021e2edf1f43385ff8a2d7d8affd358fc0e31 SHA512 95900e4347c1f7d0aa5b2e8fbf43fac6410dd6bbbac988fb3f407a964d0aa1dc51fe3cf17459e6ce762a02b45bb3d20b539ca05727278d120aee9500cf0d208a
+DIST bleach-6.1.0.tar.gz 202119 BLAKE2B d2da448feabe61431b176092f713f6f85790c22d3869a8d94f5c9659e481fd4a0b8e230eb72687e4da8914956a8858a2a5f942169ae2324d7762c5e1f20cc0ef SHA512 d7c9e77decd5eb0aceb4b33ad7e213683354aa702508f332dd6be15a14010d3795c2115acbae964cbaeff3e74c15d35eb18268d8fd8286e2cd6ad1c0dc79a838
diff --git a/dev-python/bleach/bleach-6.1.0.ebuild b/dev-python/bleach/bleach-6.1.0.ebuild
new file mode 100644
index 000000000000..7e7d3e8c4722
--- /dev/null
+++ b/dev-python/bleach/bleach-6.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="
+ https://github.com/mozilla/bleach/
+ https://pypi.org/project/bleach/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/bleach-6.0.0-py39.patch
+)
+
+EPYTEST_DESELECT=(
+ # this package is not really maintained anymore
+ 'tests/test_parse_shim.py::test_urlparse[\t :foo.com \n-expected8]'
+ 'tests/test_parse_shim.py::test_urlparse[ foo.com -expected9]'
+)
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.parse:urllib.parse:' \
+ bleach/parse_shim.py || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py \
+ bleach/sanitizer.py \
+ tests/test_clean.py || die
+ # indirect html5lib deps
+ sed -i -e '/six/d' -e '/webencodings/d' setup.py || die
+
+ distutils-r1_src_prepare
+}