summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-07 15:47:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-07 15:47:43 +0300
commit731d715e68ebf5437dce89d82eab776357c93553 (patch)
treec75aded7c583bcab7ff2061998654398096a3ed6 /dev-python/bleach
parentapp-text/cmark: remove old version (diff)
downloadgentoo-731d715e68ebf5437dce89d82eab776357c93553.tar.gz
gentoo-731d715e68ebf5437dce89d82eab776357c93553.tar.bz2
gentoo-731d715e68ebf5437dce89d82eab776357c93553.zip
dev-python/bleach: add 4.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-4.1.0.ebuild43
-rw-r--r--dev-python/bleach/files/bleach-4.1.0-py39.patch36
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 20884777f2b9..4fb539b48ecb 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-4.0.0.tar.gz 183459 BLAKE2B 380e94163b353e9436748fc6c1f368fb4d261087c2d6bc6fab1262295d597dbe81a67c34b889a29fd6a5180b8b522b517dc234e78b26556a16845f26f83151c8 SHA512 21f2a2dc5fa5e09cc2e38325191d7dc0bff2606cbe68ade54d866e326e712cb00a80b3a7a44f844ad4967ee6fdf453cca07d02c337bf147e4a12237231bcd99f
+DIST bleach-4.1.0.tar.gz 195798 BLAKE2B 68afd58aa099acb5c21f1ff76301c46834f326ea2aa4fe7a6f820c2cf31913e81dc72deecab4272b2a7ceab1ae01bec028a5cf5e6214cddef4cdec5ec05ea4c6 SHA512 34c522dde5126995789e23fd28f7938d025f56e97e30814dc326d33a772d40fc2ad2f25aed0b367fd4352b1e1e8f54b80282b931819203bf60448ffe2f120622
diff --git a/dev-python/bleach/bleach-4.1.0.ebuild b/dev-python/bleach/bleach-4.1.0.ebuild
new file mode 100644
index 000000000000..0dc5d1156b83
--- /dev/null
+++ b/dev-python/bleach/bleach-4.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="
+ https://github.com/mozilla/bleach/
+ https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.0-py39.patch
+)
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py \
+ bleach/sanitizer.py \
+ tests/test_clean.py || die
+ # indirect html5lib deps
+ sed -i -e '/six/d' -e '/webencodings/d' setup.py || die
+
+ sed -i -e '/import/s/parse/urllib.&/' bleach/sanitizer.py || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/bleach/files/bleach-4.1.0-py39.patch b/dev-python/bleach/files/bleach-4.1.0-py39.patch
new file mode 100644
index 000000000000..8460be601a23
--- /dev/null
+++ b/dev-python/bleach/files/bleach-4.1.0-py39.patch
@@ -0,0 +1,36 @@
+diff --git a/tests/test_clean.py b/tests/test_clean.py
+index 8f816f9..2be6f7b 100644
+--- a/tests/test_clean.py
++++ b/tests/test_clean.py
+@@ -525,31 +525,16 @@ def test_attributes_list():
+ {"protocols": ["http"]},
+ '<a href="example.com">valid</a>',
+ ),
+- (
+- '<a href="example.com:8000">valid</a>',
+- {"protocols": ["http"]},
+- '<a href="example.com:8000">valid</a>',
+- ),
+ (
+ '<a href="localhost">valid</a>',
+ {"protocols": ["http"]},
+ '<a href="localhost">valid</a>',
+ ),
+- (
+- '<a href="localhost:8000">valid</a>',
+- {"protocols": ["http"]},
+- '<a href="localhost:8000">valid</a>',
+- ),
+ (
+ '<a href="192.168.100.100">valid</a>',
+ {"protocols": ["http"]},
+ '<a href="192.168.100.100">valid</a>',
+ ),
+- (
+- '<a href="192.168.100.100:8000">valid</a>',
+- {"protocols": ["http"]},
+- '<a href="192.168.100.100:8000">valid</a>',
+- ),
+ pytest.param(
+ *(
+ '<a href="192.168.100.100:8000/foo#bar">valid</a>',