summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/bluelet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/bluelet')
-rw-r--r--dev-python/bluelet/Manifest1
-rw-r--r--dev-python/bluelet/bluelet-0.2.0.ebuild28
-rw-r--r--dev-python/bluelet/metadata.xml15
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/bluelet/Manifest b/dev-python/bluelet/Manifest
new file mode 100644
index 000000000000..ffdd1df610a9
--- /dev/null
+++ b/dev-python/bluelet/Manifest
@@ -0,0 +1 @@
+DIST bluelet-0.2.0.tar.gz 14182 SHA256 4af029c8247be0b4852c8e92a745178882fa7fe5d4e669e1788184581fad3f01 SHA512 58bd8df4b61f23a53f9310b68e5754155c00d598c9bcb7724e90ef6722ee5d6017751c2e056eaaa64cca71b89c391d248c14477457f30ebf2b28841a3fdc98fa WHIRLPOOL b29994733f5d6735adc9e97a83bfa86d9ca56c39ef090003923dd7ed1bedc3528ca9dea80d86fd1e429dfec09f01b6f0bee2006377c7af03ce103ed68c374f7a
diff --git a/dev-python/bluelet/bluelet-0.2.0.ebuild b/dev-python/bluelet/bluelet-0.2.0.ebuild
new file mode 100644
index 000000000000..69eeda994529
--- /dev/null
+++ b/dev-python/bluelet/bluelet-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for pure Python asynchronous I/O using coroutines"
+HOMEPAGE="http://pypi.python.org/pypi/bluelet"
+SRC_URI="https://github.com/sampsyo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ if use examples; then
+ docompress -x usr/share/doc/${P}/demo
+ dodoc -r demo/
+ fi
+}
diff --git a/dev-python/bluelet/metadata.xml b/dev-python/bluelet/metadata.xml
new file mode 100644
index 000000000000..fdb746fc31a5
--- /dev/null
+++ b/dev-python/bluelet/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+Bluelet is a simple, pure-Python solution for writing intelligible asynchronous socket applications. It uses PEP 342 coroutines to make concurrent I/O look and act like sequential programming.
+
+In this way, it is similar to the Greenlet green-threads library and its associated packages Eventlet and Gevent. Bluelet has a simpler, 100% Python implementation that comes at the cost of flexibility and performance when compared to Greenlet-based solutions. However, it should be sufficient for many applications that don't need serious scalability; it can be thought of as a less-horrible alternative to asyncore or an asynchronous replacement for SocketServer (and more).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sampsyo/bluelet</remote-id>
+ </upstream>
+</pkgmetadata>