summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-19 05:13:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-19 06:27:44 +0200
commit7e46700bf2f8f6297908bfbf87e0a66dff8e609f (patch)
treee9c2e98f0efd9eec566f472c545dadbf3d070a3a /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.22 (diff)
downloadgentoo-7e46700bf2f8f6297908bfbf87e0a66dff8e609f.tar.gz
gentoo-7e46700bf2f8f6297908bfbf87e0a66dff8e609f.tar.bz2
gentoo-7e46700bf2f8f6297908bfbf87e0a66dff8e609f.zip
dev-python/boto3: Bump to 1.35.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.22.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 65c1bb883acb..f2a689fa9136 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.35.14.gh.tar.gz 859166 BLAKE2B eb201a319453097068b4711356ea930de739
DIST boto3-1.35.19.gh.tar.gz 861578 BLAKE2B 5011df66763e646768232a65022080ffbe3db08253f1bf3e192cf57be010ccdd08f8add78ec365e1c04d78ba1722cf6ef54fbc170f7f2419fcd370c08d48e3ce SHA512 faabd3ef8eb35a323ed64a711e0a026f8f77974516b05a93d389fb82b84932f69a2c784a1065811699dac4db016549f3756f24b879485b2dfb6ca380e6873670
DIST boto3-1.35.20.gh.tar.gz 862207 BLAKE2B 06a45feaba2a8afdd213a6c059e3a3dce2608ab5f55bdccd17478be8b865ad3dddef2459481f4565bbb44736bf6ae2a68bbd26dcd1e3f0e12afc03290dc8433f SHA512 59854e97f957b58c391111aae2538771003414c04d46d50006306b84b3566dd7b1d369e68ecc658e66c04fdf89541184063aebec7859387503fbea2cfd40ea08
DIST boto3-1.35.21.gh.tar.gz 862801 BLAKE2B 44f322177603bad3de23dc47d95dc8b80b442762986a4402ec441c96cbbaa4708a3a9532c477983c0e0d857975f42ee980e61328ac72dc8bd68151980014dba1 SHA512 67bf2a8051bb08c1b761f1a13df41806356c67826e7cc6bd3c38f82ff709e6baac43430ed720f8d1f31a7e6c1fb7e4bf14bf67e8fd66db3f133ba8b8c93384c3
+DIST boto3-1.35.22.gh.tar.gz 863521 BLAKE2B 758d3b7ad49d147278e5a3cbe222fdc1b21f925343c491b4f1708762e70e7b5cc89eb3003e3b8fd1430b8b04f8d9a59c7002c404597a03321a4a57c8827a5a5d SHA512 ad7524fd5850fd77d4f3f5ca5a94c3674639c3b4e7b6d65881cf2e546f8c5f9217d2513b43435b1a9ab97a63c9d94c20f00a3791a5fba52590b2eb4c5453bf22
diff --git a/dev-python/boto3/boto3-1.35.22.ebuild b/dev-python/boto3/boto3-1.35.22.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.22.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}