summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 08:39:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 10:13:32 +0200
commit9a1354439762ebb347513fa80ffec739df629cdf (patch)
tree57e709051b9964b0bbffc70f620ea96ad0052116 /dev-python/boto3
parentdev-python/botocore: Bump to 1.25.2 (diff)
downloadgentoo-9a1354439762ebb347513fa80ffec739df629cdf.tar.gz
gentoo-9a1354439762ebb347513fa80ffec739df629cdf.tar.bz2
gentoo-9a1354439762ebb347513fa80ffec739df629cdf.zip
dev-python/boto3: Bump to 1.22.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.22.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 274d64dd6936..5f916b481a5c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.21.42.tar.gz 488786 BLAKE2B eba75a62e2460aeb2ea66641fadb52448314e63
DIST boto3-1.21.46.tar.gz 491253 BLAKE2B f55d30087e4f29e3d8ba577d798cd4e4c5fe1f710ac172d6684f005047a422855a6fad91aaaac76e3f33260cbac35be81c8177a80bea913283bcbe7bacb3750f SHA512 0d219b1af786583318a078413a3b30999b2aaad985db72eafe2b63f0068996f0d13b7a48464909cc753d5f9098ea583336ef4887839db5375ebdfcedad3dbffa
DIST boto3-1.22.0.tar.gz 492175 BLAKE2B cce4b21c0f4de7e70b1c9e402d9e19ccda26e7fc6eab07686c378ae8a9a72a7cf3bb3e2927282e21cd167ca395d63e1fbdfb31d385e5e7a2591c48367c80517c SHA512 b4c51a26e95344ec6e4b876d88148c9603ae7807105ffd0564d928f611c278729f00efd38baff4b31154b358b17ae72c6b90698aef9c013b601bc70d543e2ffb
DIST boto3-1.22.1.tar.gz 493753 BLAKE2B bd58778f89b792b3203b4b8f86edaca2149ebc24399af9ffa090d9c8ccfa812a078e2d6742bafd08197e39e5020da16948fabb685a448b7acf7ce520321c94cd SHA512 0a8d02325331bb2e069fd1f7280a3c57dae8f6a25f6593db8a1c7998f765d2957765a71645a748da891e66d5ccee859d34171fabea08de62e13ee7793c0d7cb5
+DIST boto3-1.22.2.tar.gz 494671 BLAKE2B c9b72c6a4b667772147235c5791ac4d08adb9e4bd690ea9e369ce712fd705dcc89b2fea4f5b2c580702cc4eb5064b3e46f1237de15e5dd812e2b88c54144d665 SHA512 ecf5d77fb5128a79001a0ccf2e141197d23c0a24d61517e191058de24498d63b13e351fb8e0bfe28f1c58c676d44b2e7f98bd80c41a2510c61d737e086c1010b
diff --git a/dev-python/boto3/boto3-1.22.2.ebuild b/dev-python/boto3/boto3-1.22.2.ebuild
new file mode 100644
index 000000000000..23a4a6fecbae
--- /dev/null
+++ b/dev-python/boto3/boto3-1.22.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}