summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 07:15:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 07:47:29 +0100
commitb7c6b1c668de036b32bc9999969d8f9e13101efd (patch)
treee97d14f002de1017be29052a925934585581c94c /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.78 (diff)
downloadgentoo-b7c6b1c668de036b32bc9999969d8f9e13101efd.tar.gz
gentoo-b7c6b1c668de036b32bc9999969d8f9e13101efd.tar.bz2
gentoo-b7c6b1c668de036b32bc9999969d8f9e13101efd.zip
dev-python/boto3: Bump to 1.35.78
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.78.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index d5d98f72f451..5fcf59d7fecc 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.35.68.gh.tar.gz 901189 BLAKE2B f7449998af169c873319d7b8748035db72c3
DIST boto3-1.35.71.gh.tar.gz 903019 BLAKE2B 48bf56c54a8eaa52c1850078a92cef7e5acb06f2d9d551414d640c6f5c5f381f2edc4ae6f582d9c1578f68d78a272142033bd41caba95577af917a492e995edb SHA512 56df8d30c0d3efc71caa6d629354e1311d944c71b5568b4154fc93c315558d600e4411ccc80abca98cb4a3adf3a3ab4f4dbce22ca06184e11d720f36f33b58d2
DIST boto3-1.35.76.gh.tar.gz 910113 BLAKE2B 3e7429976b348e29ba4184bffe03c643b85dd978cc520b924263e8430b5e5935b95152cced2f6c0807c65de4e6e1405c55bb24565ac5bc425292e9adac178c03 SHA512 132f37e77b7b36d525e9cf678fe2f624eed77a9eb9fa8e7d7f079a362e5d7a5f3edcd17c7d8bc1e27570171927d26e74a94d267a1b0cbddda3890ac6a0f21cdc
DIST boto3-1.35.77.gh.tar.gz 910574 BLAKE2B a843c871e53069a7a3c818e326ea5c32d506873e2381057d269e4a04f5e3be9d37aeb6e38bff4051c4d4ce3ae30e41253008785ac9bca329a17bea0f914bdc0c SHA512 e0de5951492860d48d68888ad734e33c6e8c3747f54c7164b0fca5ee9cbf2ec84e2a1a04f2b5566874bb086dcbdd096f588def36d11038663a2762bccbaf7c8e
+DIST boto3-1.35.78.gh.tar.gz 911245 BLAKE2B 2afcee97ef800b934c7f5cc2046831cb48b277951f77dc9aa844dfae4e7f9fc33b36b9d1e58a727485720ffd66ce3440c7f6d103e771b43ac355634110b14d88 SHA512 d73db44fdcdeb7d82e755c1b66084d7e47884c880e615b537f9388a9dda97d8e825613567f7ce94eb5972880b790fe841ca3765c8689c1387ec69dc0cba667e7
diff --git a/dev-python/boto3/boto3-1.35.78.ebuild b/dev-python/boto3/boto3-1.35.78.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.78.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}