summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-18 05:23:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-18 05:23:07 +0200
commite468c4391ec128c135f9693b3a091e18fc0c6252 (patch)
tree90c8542d3784096cce6c7ad2eee68fa64ff0c55c /dev-python/boto3
parentdev-python/pyproject-fmt: Bump to 2.4.3 (diff)
downloadgentoo-e468c4391ec128c135f9693b3a091e18fc0c6252.tar.gz
gentoo-e468c4391ec128c135f9693b3a091e18fc0c6252.tar.bz2
gentoo-e468c4391ec128c135f9693b3a091e18fc0c6252.zip
dev-python/boto3: Bump to 1.35.43
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.43.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 50ceb13871c4..6ab71790ef22 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.35.39.gh.tar.gz 872172 BLAKE2B 1baad362b9bfcf68ea89c9ba9ea473fcf245
DIST boto3-1.35.40.gh.tar.gz 872596 BLAKE2B eb1f81634ce0624da14d5a8c5edbe531917bb8110bb196ee9661cebda564787bb7a1506bba5b446e8eeb1392b503ec123e130ff08c0cc112131e4508147460f0 SHA512 dab1212aff42cfbf2070222e9e54adf5d4cd5237537f2b9e95e7d0d5ab909b79be8af11de57f8e30a1167fa1baf8fd96c27d4ae4c23b6030735cda99f8304415
DIST boto3-1.35.41.gh.tar.gz 873340 BLAKE2B 60d2b03b92fb49b1b4ef4208f406df8640b4a297672d12272b9c0e3867c61dfb879cdba0d93d840902d015e9b5889be823009877e2b437cecc0b0cacb8f39818 SHA512 8efe0beb7a604e8208c0039a7c94ec8a70ca2da91cafc76dcf5b442cf6a4bf0e992c113500d8c2b22f9312daef0d50e402747ae74e2ccf333411d4b6856e38c2
DIST boto3-1.35.42.gh.tar.gz 873736 BLAKE2B 1de9c16155ee6c9a23af028e074a10c37d6874a9076aa66088712438c5308d37ebadca4c03d842d2d82bc629ff0be306e66c49e65af4d55e8334777ec624beda SHA512 c7a1f8f83f9e41abc7a0690442fc8cd48c411605f702ee11521401010a30fc7dc25bf07a72881e3892c2fe268201e61baabafbf6eae8eb5e916439867600cc43
+DIST boto3-1.35.43.gh.tar.gz 874500 BLAKE2B 6db4f4739e52e1b3e897d3309fcddcc45c993f80077347c83420a6be38c7163f673445475cc268bc62fa3b2d07fead64de33aff09497559fb1044c1cac2e65ea SHA512 bea6debe174fc842e2dcc86ee065f2ac789102b5252f762b4424235cdaebe19908f1461404fcb31641920a160f056b1645d9866ce191f3f1624babdf30249ddd
diff --git a/dev-python/boto3/boto3-1.35.43.ebuild b/dev-python/boto3/boto3-1.35.43.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.43.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}