summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-29 06:20:55 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-29 07:51:24 +0100
commitf0bde9762e5964c0a15bc011b1d8f84f4e24499b (patch)
tree2e3c7e0c26e6802d0fffaba6154cb6695daaacde /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.50 (diff)
downloadgentoo-f0bde9762e5964c0a15bc011b1d8f84f4e24499b.tar.gz
gentoo-f0bde9762e5964c0a15bc011b1d8f84f4e24499b.tar.bz2
gentoo-f0bde9762e5964c0a15bc011b1d8f84f4e24499b.zip
dev-python/boto3: Bump to 1.35.50
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.50.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1b508319d192..01769b952541 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.35.39.gh.tar.gz 872172 BLAKE2B 1baad362b9bfcf68ea89c9ba9ea473fcf2451a71be8121a443830622114b3577ae83500aaa0cbef86115e24d276ffa5660fa6e9c08d2358fa493367405fc8dd4 SHA512 4244e71a3773d9abfa419c34220fa2c44c90a93b11b8338535582aee8fe9cd788672d6833ae97f1b32fb6479b9be97f1b2db953f24b403b07f2ee3153bc833aa
DIST boto3-1.35.44.gh.tar.gz 875230 BLAKE2B 68c4fa6739a5d9cb720670a1bc14079ffac4b23101bd27367ec81675a34d717341c87257864a658c60d8a0c5fdea298f73db979b6aa64f65e9ea54479005d33b SHA512 6ff24f42088ae9f77b5e1ff033fab34c6a0c0f7fc46cf9cbe172b3151cf259e48c3804981afbc8de893dc2541105a04bc00d6becd3220c18243bda7ed206740b
DIST boto3-1.35.49.gh.tar.gz 878577 BLAKE2B 8f9ddf29eaad2f91a9ba670b268ac987f7f813dea52427a559b245111042f84b8593158bf1f3dbec353b9fb92116be39e739326dbdd70366589ee507a994da4d SHA512 3a1aa9bb8c8aa384abdc2a139273364c49f608921ff9c4ce9e96b4b93d11bb145a45ac65df6245912ba3be6d4e8f0df86e407d74610837b149f81712529b3152
+DIST boto3-1.35.50.gh.tar.gz 878776 BLAKE2B 23b43830c16657e688bec46b65ae784fa8f70c5849f809bf71a4ab73533d43efd76a56bf0694d99a488bffed42896f034fe0b4680705093bd59d0dd86904c721 SHA512 91b66821f5698f09ef61851fe8419cfbe2b85f1a586858a490d12ef63ef2309af76b5393aeeb3a6b31a74a1d2dc46712750fe4b75dc627dc55fd681a5b019edf
diff --git a/dev-python/boto3/boto3-1.35.50.ebuild b/dev-python/boto3/boto3-1.35.50.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.50.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}