summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-11 09:08:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-11 09:48:08 +0100
commit06d284aea0c03519582939b95ef5b8100d8923f5 (patch)
tree2a9afc296cb85c8b62753fa1f7b31d3c6d73767a /dev-python/botocore
parentdev-python/pytools: Bump to 2021.2 (diff)
downloadgentoo-06d284aea0c03519582939b95ef5b8100d8923f5.tar.gz
gentoo-06d284aea0c03519582939b95ef5b8100d8923f5.tar.bz2
gentoo-06d284aea0c03519582939b95ef5b8100d8923f5.zip
dev-python/botocore: Bump to 1.20.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.25.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7aee34d487f5..056a9409f150 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,4 +8,5 @@ DIST botocore-1.20.21.tar.gz 7489798 BLAKE2B edaea4e14515e5ce5d1a84dcc466f9cc272
DIST botocore-1.20.22.tar.gz 7499474 BLAKE2B 14394f8de4de39d8073548409f08615452a1d3059a13287549e16ab8815dbf1ac975e0c116ebcbe7acb86055df29ca8d9f2e251f56386ed3cf15922eee9e5f1f SHA512 1c67de2456d5933a67966b0497492acec2954a2a397c856f54d06aa642ee286b8975a52d0df6b2b814bc817ae129b9965b0d5ba6711c75585b0e2127bcde823f
DIST botocore-1.20.23.tar.gz 7499542 BLAKE2B abcc28ec69d30ddff06ac2e2f3e2c0dcd7311c6a4ba676c9d11059fa5f66de3cebf93b37b88da6204f74ce77e3dbf9da6829be7f9f0c62abb14310a6a2863c34 SHA512 d44d5619ffb288c99f9c5638ab84466a5776df986525a258349264697fd85842b25f67b177fb5a5cf87a5aade81fbbc87b731d4e7a8ff9156cfe12814fc915ec
DIST botocore-1.20.24.tar.gz 7503493 BLAKE2B fdc1de907a8201ecc63435b2f3cef38ec40ac8cb6b23bf20140db3d5def46dae3a6d66ee0f1cf268bfa63fa9cbcd7f0835570a91b3c538c3303350499e3a1964 SHA512 26ab23f2b3fb8c5b6b0fbd3045761ae81b4abf07c3457307a3b79f7b2a3840b5f1bca5ca669aa98d2465c9c39bb1250f93f2254bace5bfc75849745804f29061
+DIST botocore-1.20.25.tar.gz 7508526 BLAKE2B 244b578cc0596e4fc6b225cd29d0b5ca2e42159dcc506ff3f0a730e3602166ca52bb1a4a2ea8049b86fe6409ac521e30d1f0ff02deec8550a4187579b9a43f9f SHA512 010aac3c0021c7406471cae2c0b13a33dde620b2d7e5df96170971459b9f425d9ffb2a3ad08a650c3097924ff12b34354983ef36336e2afd0172fc3a73f988e7
DIST botocore-1.20.7.tar.gz 7458254 BLAKE2B 8b9a1edda73e2564d3a3d67c6b3542d1ec9372403cb4d88396e58dfbcb5987821f278f2757e079e1ab32e03243ed3a6d1023ecc591b965512b3af5e2d43ea7b0 SHA512 9b023a31be866a50b94017a28aca40b5fe2e720959c928a3fd93db96041f3886049717f50461222a09572c0c56c5961a4614b80e400e4fa6d8b3ff4b4ab681df
diff --git a/dev-python/botocore/botocore-1.20.25.ebuild b/dev-python/botocore/botocore-1.20.25.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.25.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}