summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-12 05:31:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-12 06:49:05 +0200
commit17272c79cf9dd73f77613e467859ce75a8ad1c3d (patch)
tree95dcc4e111af21ab76a468e2b0e815c7b270b7cd /dev-python/botocore
parentdev-python/uvicorn: Keyword 0.21.1-r1 sparc, #904191 (diff)
downloadgentoo-17272c79cf9dd73f77613e467859ce75a8ad1c3d.tar.gz
gentoo-17272c79cf9dd73f77613e467859ce75a8ad1c3d.tar.bz2
gentoo-17272c79cf9dd73f77613e467859ce75a8ad1c3d.zip
dev-python/botocore: Bump to 1.29.111
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.111.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5962aa42cfdc..48e6fe80af72 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,4 +4,5 @@ DIST botocore-1.29.107.gh.tar.gz 11367875 BLAKE2B 3a7ee035770752f848ebe47db9801c
DIST botocore-1.29.108.gh.tar.gz 11370922 BLAKE2B 9f639ba9df35dfdd282021d258f6a40b5bc80a1cb918db56479c10854f6ae5d0e179dd6840baa39bdb229b2e42c7f40522cd6bec3db340bc7950f3557d0b3f63 SHA512 cb9632afbc12233a0483ca6eb93d2bc77814b859707e3db9c72ec5a33ea2a0f8c5c2215ab49e510ee356a0f222905fd4b6c262c8a0c30e104aa0e6842871faed
DIST botocore-1.29.109.gh.tar.gz 11375235 BLAKE2B 9bd6333319cce685257a5bd4eb06d289946b0706ff5ee6786d965bcab64d858a967812e0692e57713e6e93fb62848898713c2a303c9e2b976f39a38af948a9c5 SHA512 d5b14de4bedd96b8396bfac997df1482b2b83cdff1469d21a7e8a6c5047b6f46bd6690f36a4de3dc54fba1121486ff6c21422d7c8b6209a877d156dff76ccd1a
DIST botocore-1.29.110.gh.tar.gz 11378477 BLAKE2B d12d1073453c0e279a2976ae9fb3c41161a7da93aec9442d3262227a22efd2e73b704a95b9aaf727cb54646dff00c52aff6021ea119f8f2e500b580f4c4eed4a SHA512 5e44492d64d65d10ae9b8a16c37497e7b121a85987d93325896f22909b111e9821c14daf77acd192ca0cabad0e56aca9c2bd99a843c7bb5823ad6f80d23df702
+DIST botocore-1.29.111.gh.tar.gz 11379381 BLAKE2B c41a3089bf088ff6e0f74d4e425653638ae518f759e4b012a8fde1db736219797b9fc89f7fd6cd3e2187068ca8ca65ae2f113a8299b5eb9c9e6caaa976fdb4be SHA512 0a3890a47ce58d60883cde87908c80a358bd5ad2770c3790b71673de70807f8803ec5887654bd72b2c74844accf90cd460c9d7520adcd9d03d5164baa035b757
DIST botocore-1.29.99.gh.tar.gz 11285143 BLAKE2B ba594544fb219cec77659cfa48fb6e3a8241b92c911d9983450648ce97652cad7654181637fed8373fe49e33524f63920128afd4ca9c00bce45603b1ab917648 SHA512 319d70412843149aa43c8d7faeff04122d96091081d30c2da0962fadb27104a24cc147fac2c95492aa407b2f8a25ebed9e7d149c29d5d38134d836581c801bdd
diff --git a/dev-python/botocore/botocore-1.29.111.ebuild b/dev-python/botocore/botocore-1.29.111.ebuild
new file mode 100644
index 000000000000..491b6bbc21f2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.111.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}