summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-26 06:52:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-26 08:01:21 +0100
commit53aee1f23b189c45739d9d95ccd7954040067c98 (patch)
treea8e5f831794a7246e97045bfdad506c81a1054e2 /dev-python/botocore
parentdev-libs/liblogging: add comment wrt docutils/release tarballs (diff)
downloadgentoo-53aee1f23b189c45739d9d95ccd7954040067c98.tar.gz
gentoo-53aee1f23b189c45739d9d95ccd7954040067c98.tar.bz2
gentoo-53aee1f23b189c45739d9d95ccd7954040067c98.zip
dev-python/botocore: Bump to 1.35.69
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.69.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5659324a2070..966463213fff 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.35.57.gh.tar.gz 13603794 BLAKE2B 23a4dc82e1d9667e75494c2fb651b883c7fbaf689679a1b40c3f277c33760fbaacd6843e6630876fe75597c6e6dc892726c609a97efcff0d46533460c379c43f SHA512 f20eccdcd0c027e3c1d6c631988c8913f3150b1b6da679fc18ea75824d0ef61b999ee9cad4f0d74edbb639cf52daf188fd7e256664e57fc89be09f33ed78d65e
DIST botocore-1.35.63.gh.tar.gz 13692343 BLAKE2B 41ded808c412e9af8f938cf64db1632478f77d082417afac1f34905e946c0459545afa46854a41458090eab26a32b2733fb164f374455d8bdefea35718182632 SHA512 7185f5a288f848e1f3810ab9fa4eb46467321af6bdd345a8de623722ee513ab89f43303955487b014a3c349ed69a62c7bdf54e5095c3f4ebfd254fab51443ca8
DIST botocore-1.35.68.gh.tar.gz 13887015 BLAKE2B f49ea77be07628c9c0a471a76b87bc2b2e0371afdfdaf6da2ad39fdc828376dff14681167a2989b440f37fc5754dae12c7160cb14fb82187acbcf07e34647fc3 SHA512 e31ff9022f29e4cacd9c6085e9c8741d799986746e34965c37e12d8ecfc3a5f4fed8e14045e9ce4f2f552f31d07641ffe8a0209d9d220b942e1b54c2e0d0f848
+DIST botocore-1.35.69.gh.tar.gz 13887079 BLAKE2B 0d1f6fbae8cad8e8c67839ef70940d8230f4cb52a6144eb2fbb8825eec51d3f94634b6af79a7943cf07c3bf7a3d239a43e2b2ba847688c74dc0a577084a6e620 SHA512 0501b403e587e3edc6a5805476a9e4bf3e7f95c0888b4c58c25b7bf46bcafc261c1a38b6b40b8fcb306dcc642fd8f00e6828daddca267e368e17abccb0723032
diff --git a/dev-python/botocore/botocore-1.35.69.ebuild b/dev-python/botocore/botocore-1.35.69.ebuild
new file mode 100644
index 000000000000..0f88c5cbe9f3
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.69.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}