summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-08 22:39:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-08 22:39:55 +0100
commitdfe26277ee7441d00d88da14691cfc48db85ac8a (patch)
tree045bc0ccf94122cb43a9d2b06c21472e3401cfb3 /dev-python/botocore
parentapp-emulation/docker: remove old 20.10.3 ebuilds (diff)
downloadgentoo-dfe26277ee7441d00d88da14691cfc48db85ac8a.tar.gz
gentoo-dfe26277ee7441d00d88da14691cfc48db85ac8a.tar.bz2
gentoo-dfe26277ee7441d00d88da14691cfc48db85ac8a.zip
dev-python/botocore: Bump to 1.20.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.23.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5a4cb10acb62..ed33ca4548db 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,4 +6,5 @@ DIST botocore-1.20.19.tar.gz 7479977 BLAKE2B 4193cb9975dcde134450968ffcf4cc07b7a
DIST botocore-1.20.20.tar.gz 7484162 BLAKE2B c9b14936ca8d59070cc99ec56fb7124c2c162f8b3473e3049f57218e41df8bc0bf20172bd65067d504e6317c917573e16d456169564d93dd969e69e87944fdb3 SHA512 aff520c93bea5b600d1c0decd20d49208b2dbf7113f435a633b4b4c68dd0dc46f04079c4e38132d03e5f9aed7a124bcdaaae55ed0126c002acd30954e9609352
DIST botocore-1.20.21.tar.gz 7489798 BLAKE2B edaea4e14515e5ce5d1a84dcc466f9cc2720f6cf996d61b1ee9fbdb4164849fd3f22fb7321e007b02b7348e6134a20623be4768875de7f7f811e7ea4591197cf SHA512 41086b8f8dac26db5ffdc8d60969f5c2accc756535323d645e44456bdf6af71929211e31e3d73b6fb3ec0367752f8646dbbed2abc0f147b4b34ad462ecd86c48
DIST botocore-1.20.22.tar.gz 7499474 BLAKE2B 14394f8de4de39d8073548409f08615452a1d3059a13287549e16ab8815dbf1ac975e0c116ebcbe7acb86055df29ca8d9f2e251f56386ed3cf15922eee9e5f1f SHA512 1c67de2456d5933a67966b0497492acec2954a2a397c856f54d06aa642ee286b8975a52d0df6b2b814bc817ae129b9965b0d5ba6711c75585b0e2127bcde823f
+DIST botocore-1.20.23.tar.gz 7499542 BLAKE2B abcc28ec69d30ddff06ac2e2f3e2c0dcd7311c6a4ba676c9d11059fa5f66de3cebf93b37b88da6204f74ce77e3dbf9da6829be7f9f0c62abb14310a6a2863c34 SHA512 d44d5619ffb288c99f9c5638ab84466a5776df986525a258349264697fd85842b25f67b177fb5a5cf87a5aade81fbbc87b731d4e7a8ff9156cfe12814fc915ec
DIST botocore-1.20.7.tar.gz 7458254 BLAKE2B 8b9a1edda73e2564d3a3d67c6b3542d1ec9372403cb4d88396e58dfbcb5987821f278f2757e079e1ab32e03243ed3a6d1023ecc591b965512b3af5e2d43ea7b0 SHA512 9b023a31be866a50b94017a28aca40b5fe2e720959c928a3fd93db96041f3886049717f50461222a09572c0c56c5961a4614b80e400e4fa6d8b3ff4b4ab681df
diff --git a/dev-python/botocore/botocore-1.20.23.ebuild b/dev-python/botocore/botocore-1.20.23.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.23.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}