summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-19 07:34:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-19 08:33:05 +0200
commitfec3db099ab029e7cfe6126f5b5b8c62524208e5 (patch)
tree6ed9085f9debd1e950bd9cff40708072a0ba2489 /dev-python/botocore
parentdev-ruby/rspec-pending_for: new package, add 0.1.16 (diff)
downloadgentoo-fec3db099ab029e7cfe6126f5b5b8c62524208e5.tar.gz
gentoo-fec3db099ab029e7cfe6126f5b5b8c62524208e5.tar.bz2
gentoo-fec3db099ab029e7cfe6126f5b5b8c62524208e5.zip
dev-python/botocore: Bump to 1.27.32
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.32.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 4f0b89e67309..0ae7d7a80b80 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.27.22.tar.gz 9151155 BLAKE2B e3aa6e9814e07bca2bd67d16f6548303af71654021b28f13c43b4005ba24a32cfccffa9a145babb781a6cbff9df3eab7de4c18973c00b3861ba83264eb144537 SHA512 57e43577840c62556760ff40d820898b0ee1efeb5da39fbdfe8c7ef53e86c8184bdfed5a52eeb9d0652fa053900462bdad9820b4a34bd4b5231f361b89c710d6
DIST botocore-1.27.26.tar.gz 9167551 BLAKE2B 9e95c1e6e5261b08247615446a589318d92cc86768c5e3999f99fb8e2a4a888309d72d4d3d66a1ebf9c1e2b6ccab6265a1d94ad9dcbf9da22aa1ae012aa2bfb3 SHA512 bbb563c2bc8eb3fe022f0b7be263ef16de93aadb02fb7a8e242f53a957a97e8f8b5d043ea8897a7b268d4d64b1e4972f2ccc91b8255f232c858f6a9ba1d93f34
DIST botocore-1.27.31.tar.gz 9184651 BLAKE2B 01dcd9e94490923f7d0f463d3019007f58c5e441ae65ea2c365ed20417e8f7b532228a335c6f461ca97411269aaa78aa48fa33cccd8b2e45a6665c2410bb4352 SHA512 27f810e0519144fae71600ea7f6d9a15cca30386ee0f2b06beeeb64c06da8728b54709fb770673f708697dd930fe744703728ce00b6a1149361ab550fef9ccb4
+DIST botocore-1.27.32.tar.gz 9191251 BLAKE2B 757aa8e1efe16db3e9bedb545c32e9013eb80fc2b0b6fd61903c2c34d4c5140cce41f7c62822b277119079bdb921102d7d1c431edc5617131ab8cd8d6983054c SHA512 3ae2d0d092961bc061d744e74bbf3a387120a400173f54f4d62284535ee2e505a887f57be7c44f306560ce6d6f82c4ff435d0a9221e8e7f406eb13c7dd26ec11
diff --git a/dev-python/botocore/botocore-1.27.32.ebuild b/dev-python/botocore/botocore-1.27.32.ebuild
new file mode 100644
index 000000000000..830c713f6036
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.32.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}