summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 14:18:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 14:18:23 +0200
commitff86349b63bcf6c19dc3485dcbeea6ac549773be (patch)
tree0739df5f68a2cc84555eed1b7a50a26c27e497b6 /dev-python/botocore
parentdev-python/zope-hookable: Bump to 5.2 (diff)
downloadgentoo-ff86349b63bcf6c19dc3485dcbeea6ac549773be.tar.gz
gentoo-ff86349b63bcf6c19dc3485dcbeea6ac549773be.tar.bz2
gentoo-ff86349b63bcf6c19dc3485dcbeea6ac549773be.zip
dev-python/botocore: Bump to 1.27.78
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.78.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 0dff3952afc4..1135466ba7ee 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.27.69.gh.tar.gz 9598373 BLAKE2B 678cfea9cee9c9dbdae1fc7d23ef8530
DIST botocore-1.27.70.gh.tar.gz 9601647 BLAKE2B 2d980a26ee0ebf6ead3a8c41f69ae02726e5984948c20855dc2428c0f0c5c775ef6cdc38544aba3e4abad7ed69b9e1929103cc990d0d2ceb95c547d7c17b0b9d SHA512 24a3066abd1b57060d4ddf89b011a238ae3bdb65b08bb1f6ea6de7e54ddc78d809d7f7ec532b95ac9583f5ffec83e7d40a531fd088a486b132fe1fb044b4ebbb
DIST botocore-1.27.74.gh.tar.gz 9626080 BLAKE2B 05f039078c207c3878f189147ac2cf838bf51d2f69d3417440cf71b10ddf952414cfbdb1c21c0ba52ee0397f3dd720b8a4e0aa6090bb77cb12ff11a370f20aed SHA512 56a78879a2315f7a5a7d809f4e6e6885dfd0d085715494448dbd0b36029c5eba00c48a12a7f49af121a22363a1680591bcc82d220cc4e34e6cb02a2404df5877
DIST botocore-1.27.75.gh.tar.gz 9628845 BLAKE2B dcce68d2d24e621d8d56d2f3417a5bbc93465d8cb889ae2243693b4e0363941a8993026b748f8b752ff7df21a4d37f507400dfaefc254c6abdeeb3e7fb3a7689 SHA512 1868ecdab142a08a3ca664dc87a9b5d15032b688b573d8deb6203e31883c4bf998059b219a5a76ddcd37fa01e44a1cc8a16ba020555921bbf12bbba7316f95fb
+DIST botocore-1.27.78.gh.tar.gz 9639497 BLAKE2B 38b3286227941216db66453201b73366ab28722f6f6e08388419b9db7bd4b25aad2c379cee6438ecc0c25fdbb732827117954454280e4aa367f1d579352f464d SHA512 bf182ac90c0d392a32f2d117145d2cbcf019ddbd3fed1205228a9b5721b08296f8948668c47b07feab6eb2ad2cf65f92a31d782c5ff3ecdf727466f7889c466d
diff --git a/dev-python/botocore/botocore-1.27.78.ebuild b/dev-python/botocore/botocore-1.27.78.ebuild
new file mode 100644
index 000000000000..d1a6948e70e5
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.78.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}