summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-08 04:46:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-08 04:52:34 +0200
commitdcc32db2ee50a9ade82f3133e59b5a675ec9c5f9 (patch)
tree22511d09456406986c6a4154ed6fc1d6a9d499e3 /dev-python/bottle
parentdev-python/inflect: Bump to 7.4.0 (diff)
downloadgentoo-dcc32db2ee50a9ade82f3133e59b5a675ec9c5f9.tar.gz
gentoo-dcc32db2ee50a9ade82f3133e59b5a675ec9c5f9.tar.bz2
gentoo-dcc32db2ee50a9ade82f3133e59b5a675ec9c5f9.zip
dev-python/bottle: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest1
-rw-r--r--dev-python/bottle/bottle-0.13.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index 4e60f8223bf3..99a6c9a88ec9 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,2 +1,3 @@
DIST bottle-0.12.25.tar.gz 74231 BLAKE2B 2856d94e1525f21e272d70ca3101188ea65417179342d7b3e971c5d1a3be77265e4197e5d29764a5739adbd984883ed121524f29e6a5933b8681e2c34b511a57 SHA512 14b8ed1ffd58f9667d451872ccf73a6f4bf8f7ffb9329f55314f90c770630cfe3f9956f786bcc7fd5f67fde22d14961952969af405912ebe71f019ca6599c975
DIST bottle-0.13.0.tar.gz 99295 BLAKE2B ad97db9c0d9313d836fc166809205b0b812e1d7ac3de05b5610aada01a19e8c785ccf8254304223fa77606f283d2e4621c5db2c5f36e950756c5ffef0bda4fa9 SHA512 17951d723c960ed045500c3721b0cccb3015c69f9e3cd2813e29984dbc16cffa63b108f18f36e0b3cf32b25bf9d900603f58569e1ab65bf53096c056d6ea6714
+DIST bottle-0.13.1.tar.gz 836422 BLAKE2B 8160de68b04cab8b3fe86dfc4b9f354ff2de523eae79277b91889e634629e9b462f9013c9821409ad3b43aa329c02ddce66bde45bc1c650a2826e641236b2fe7 SHA512 504704d20712723436c61712e8aa41e603a0f66f74927b4d4122aaea3a090ab910d5daa12217d48b803a66fc3d96d491c2a0b30df236aff50520adb8c115609f
diff --git a/dev-python/bottle/bottle-0.13.1.ebuild b/dev-python/bottle/bottle-0.13.1.ebuild
new file mode 100644
index 000000000000..e4376f17d3e4
--- /dev/null
+++ b/dev-python/bottle/bottle-0.13.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="
+ https://bottlepy.org/
+ https://github.com/bottlepy/bottle/
+ https://pypi.org/project/bottle/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}