summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-06 10:01:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-06 10:27:08 +0100
commit062e8ee25d36083c3a0543176e7cf37568cd19d1 (patch)
treee9834ae92a09cf4c292b7aae504073c342d26bea /dev-python/brotlicffi
parentdev-python/stripe: Bump to 2.55.2 (diff)
downloadgentoo-062e8ee25d36083c3a0543176e7cf37568cd19d1.tar.gz
gentoo-062e8ee25d36083c3a0543176e7cf37568cd19d1.tar.bz2
gentoo-062e8ee25d36083c3a0543176e7cf37568cd19d1.zip
dev-python/brotlicffi: Bump to 1.0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/brotlicffi')
-rw-r--r--dev-python/brotlicffi/Manifest1
-rw-r--r--dev-python/brotlicffi/brotlicffi-1.0.9.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/brotlicffi/Manifest b/dev-python/brotlicffi/Manifest
index 66208cc556e0..58c38dd88d8b 100644
--- a/dev-python/brotlicffi/Manifest
+++ b/dev-python/brotlicffi/Manifest
@@ -1,2 +1,3 @@
DIST brotli-46c1a881b41bb638c76247558aa04b1591af3aa7.tar.gz 19840371 BLAKE2B b9a1c3c2e5b62bd63b392debe54bd1732ac1cb31f88500f0142108b453649d96901d9a03b6db98642cb9abaf9188c06d440f2b8bd3cf57fbbb52196a931f5079 SHA512 dc573c90491032a205f32f0ce9c93e95b06c70a3107caa9501e038a212226c37117d63709a29843367344bf7d18cf32d0c0578b11166387198e12b38b1522406
DIST brotlicffi-0.8.0.gh.tar.gz 21997 BLAKE2B 5e817e228ce01cd7a831c59cca5bab3e851d676f1daa5efab8f61a203c0854bcc92605c88896dff5f4ce27fc880718da5ddfcf02a3bddbbd7b2e18c33f1e77a4 SHA512 fd0c64b400d3b48e0e2d113b4d75e32a2b33fd99505c7661d6d51ba9aedf5cc1f58be09bc90a5f1f7e3424addef2b54cc085a41e6291c87d53dd7d4e8fc7eb4e
+DIST brotlicffi-1.0.9.1.gh.tar.gz 22589 BLAKE2B 14ebb3f6168d334abe3ba72bd88697ee98aba87ace6aaf634395ef50ecd9325723f0da0a9ce56a5e4dcfebfe3183a190e2ec183eff95492b25e3542161b32322 SHA512 669c73ed6dd18be6b916bb8cfb240657dcc10d67df5a32b3359f05cadf75aa654c27b53e8b964251f6d6cd74870e159efddf87ef0cfb59b7777eacd3cda66852
diff --git a/dev-python/brotlicffi/brotlicffi-1.0.9.1.ebuild b/dev-python/brotlicffi/brotlicffi-1.0.9.1.ebuild
new file mode 100644
index 000000000000..a0aa1519e853
--- /dev/null
+++ b/dev-python/brotlicffi/brotlicffi-1.0.9.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+# Commit of the Brotli library bundled within brotlipy.
+BROTLI_BUNDLED_COMMIT="46c1a881b41bb638c76247558aa04b1591af3aa7"
+
+DESCRIPTION="Python binding to the Brotli library"
+HOMEPAGE="
+ https://github.com/python-hyper/brotlicffi/
+ https://pypi.org/project/brotlicffi/"
+SRC_URI="
+ https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/google/brotli/archive/${BROTLI_BUNDLED_COMMIT}.tar.gz
+ -> brotli-${BROTLI_BUNDLED_COMMIT}.tar.gz
+ )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-arch/brotli:=
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "brotli-${BROTLI_BUNDLED_COMMIT}"/tests "${S}"/libbrotli/ || die
+ fi
+}
+
+src_configure() {
+ export USE_SHARED_BROTLI=1
+}
+
+python_test() {
+ local deselect=(
+ # incompatible with USE_SHARED_BROTLI=1
+ test/test_compatibility.py::test_brotli_version
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}