summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-15 08:43:10 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-15 10:18:22 +0200
commiteaefe8a11c1909c58ad2b6bfd35c743f44633b42 (patch)
tree7313d905a38b9b77a1daeeebb6d5669d2dfc6777 /dev-python/capturer/capturer-2.1.ebuild
parentsys-cluster/cinder: liberty bup (diff)
downloadgentoo-eaefe8a11c1909c58ad2b6bfd35c743f44633b42.tar.gz
gentoo-eaefe8a11c1909c58ad2b6bfd35c743f44633b42.tar.bz2
gentoo-eaefe8a11c1909c58ad2b6bfd35c743f44633b42.zip
dev-python/capturer: New package, ebuild written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/capturer/capturer-2.1.ebuild')
-rw-r--r--dev-python/capturer/capturer-2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/capturer/capturer-2.1.ebuild b/dev-python/capturer/capturer-2.1.ebuild
new file mode 100644
index 000000000000..46af8fcbd1ce
--- /dev/null
+++ b/dev-python/capturer/capturer-2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.org/ https://pypi.python.org/pypi/capturer https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# Test fails only ebuild, but works manually
+# Can't find out what it is
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}