summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-06 14:38:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-06 14:38:19 +0200
commitfb0b5f46dcf5fcfc6dd27ac0260e586c298b0b5c (patch)
tree2991d9e113c111e070978221c70f5f2f6580119f /dev-python/cfn-lint
parentdev-python/threadpoolctl: Remove old (diff)
downloadgentoo-fb0b5f46dcf5fcfc6dd27ac0260e586c298b0b5c.tar.gz
gentoo-fb0b5f46dcf5fcfc6dd27ac0260e586c298b0b5c.tar.bz2
gentoo-fb0b5f46dcf5fcfc6dd27ac0260e586c298b0b5c.zip
dev-python/cfn-lint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.86.0.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index cb8a105a2427..574943cfdab6 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,2 @@
-DIST cfn-lint-0.86.0.tar.gz 3847186 BLAKE2B 8edc25b25bd385717f7c1cd7d79cc910ec87c5232daec70cd448659e56cd710524532b66e3392d369b787765613a83bf37180f5f64bd489ec9c32d24cb6a3963 SHA512 4dc131c2cfc2d9892c6835a505bc5cc9a3d570cc22750bbb239b577417b010de7cfd0b17caeae44197b2cecbdf163973e447906eae778aba84834ebce3b5d0b3
DIST cfn-lint-0.86.1.tar.gz 3865324 BLAKE2B b5b31d12dde1e0d5d3f8da42cf22bb6cc7c2a6b87f12edc3bdbaed5b51da013f24c58ce4cb2a6e0a412ba153b15f6ac46cce194f9617bd493041d922025ba067 SHA512 b396b68a93782e018b0690dc33430d4f013d597f78e66218af3058fd97c766e4c36ab5d78a0b620b0838b55e6197bef66580f1c3cd98320ddd29ec1ff91bd6c2
DIST cfn-lint-0.86.2.tar.gz 3918328 BLAKE2B c46528a4de5ae26554a5c7099ac87c7b5984bd3b7c602f87991b441b7678442202f9a669814b356efe8dbf9287e7f911ccf6641bb738d0900a9e059915ee536e SHA512 a7f7ce49ea2acfa5c32057ae01c1ed4cf8b9e8caee854ee91a6631b200c289e9cf2169d918fe997ad44f0ab21507894e5d6c5f18a06f563373384da003a139f4
diff --git a/dev-python/cfn-lint/cfn-lint-0.86.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.86.0.ebuild
deleted file mode 100644
index f16930764886..000000000000
--- a/dev-python/cfn-lint/cfn-lint-0.86.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="CloudFormation Linter"
-HOMEPAGE="
- https://github.com/aws-cloudformation/cfn-lint/
- https://pypi.org/project/cfn-lint/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/aws-sam-translator-1.85.0[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
- <dev-python/jsonschema-5[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
- dev-python/junit-xml[${PYTHON_USEDEP}]
- <dev-python/networkx-4[${PYTHON_USEDEP}]
- >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
- >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
- >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
- >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin the deps
- sed -e 's:~=[0-9.]*::' -i setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- test/unit/module/test_template.py::TestTemplate::test_build_graph
- # requires git repo
- test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
- # Internet
- test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
- test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
- # TODO: it looks as if AWS_DEFAULT_REGION didn't work
- test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
- test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
- test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
- test/unit/module/core/test_run_cli.py::TestCli::test_template_config
- )
-
- # from tox.ini
- local -x AWS_DEFAULT_REGION=us-east-1
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}