summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-18 19:56:47 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-18 20:06:17 +0100
commit0201fcda40b26a6960e402a3b7e53e6a5ab44ee9 (patch)
tree02d3977e738dd85a78101293856bdc4a0d4e4b77 /dev-python/cheroot
parentdev-python/qtawesome: Remove old (diff)
downloadgentoo-0201fcda40b26a6960e402a3b7e53e6a5ab44ee9.tar.gz
gentoo-0201fcda40b26a6960e402a3b7e53e6a5ab44ee9.tar.bz2
gentoo-0201fcda40b26a6960e402a3b7e53e6a5ab44ee9.zip
dev-python/cheroot: Bump to 8.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest1
-rw-r--r--dev-python/cheroot/cheroot-8.5.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index ab822216c15f..63f73bf8dd17 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -1 +1,2 @@
DIST cheroot-8.5.0.tar.gz 112163 BLAKE2B f7105f7c2d5433b90832dff6404120f153783b644b5acab72a915899fd138df1ee9ecde6d4148a66472cfb31802e58d684256524a212c65c1c42a22ab7783ce2 SHA512 3e781bfaea0b1d0b339ddb1ef871505c7eb0f4a67873f3207ec3cbb703392f579de90785c196d77f7a484b675de1438def4ad91109e70ad5894d26e55c645a01
+DIST cheroot-8.5.2.tar.gz 113183 BLAKE2B a3b60a9df3f34913cfb8c99fbdc8580ea436710c7979e296c18a6981f54bb959d6a300f4cf9d4e608fe2987f58d5fc6d2b8f57bca800e461d31c77ac61fd6b01 SHA512 245c4157f5e11741d94375099878ef5b31945412a2b02961502e762b9770fd968f4f977fe2d74744aa6596c668079d7f07b6f129fa11438783a95d3a5ee088fa
diff --git a/dev-python/cheroot/cheroot-8.5.2.ebuild b/dev-python/cheroot/cheroot-8.5.2.ebuild
new file mode 100644
index 000000000000..a679521746ed
--- /dev/null
+++ b/dev-python/cheroot/cheroot-8.5.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+HOMEPAGE="https://cherrypy.org/
+ https://pypi.org/project/cheroot/
+ https://github.com/cherrypy/cheroot/"
+SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.11.0[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e '/setuptools_scm/d' -i setup.cfg || die
+ sed -e '/--cov/d' \
+ -e '/--testmon/d' \
+ -e '/--numproc/d' \
+ -i pytest.ini || die
+
+ # broken
+ sed -e '/False.*localhost/d' \
+ -i cheroot/test/test_ssl.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}