summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-14 05:23:40 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-14 05:57:33 +0100
commita652d070970af44389e0124e6b7e77f5662ec05d (patch)
treeea157a255ae6f7b46a315f13182ba8a6ab09e5f4 /dev-python/cliff/cliff-4.2.0.ebuild
parentdev-python/openstacksdk: Bump to 1.0.1 (diff)
downloadgentoo-a652d070970af44389e0124e6b7e77f5662ec05d.tar.gz
gentoo-a652d070970af44389e0124e6b7e77f5662ec05d.tar.bz2
gentoo-a652d070970af44389e0124e6b7e77f5662ec05d.zip
dev-python/cliff: Bump to 4.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cliff/cliff-4.2.0.ebuild')
-rw-r--r--dev-python/cliff/cliff-4.2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/cliff/cliff-4.2.0.ebuild b/dev-python/cliff/cliff-4.2.0.ebuild
new file mode 100644
index 000000000000..d6f9228178d6
--- /dev/null
+++ b/dev-python/cliff/cliff-4.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest