summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-23 04:23:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-23 04:37:12 +0100
commit38efbeadb26e5b24ef98cb2ffda0e3494a035dbd (patch)
tree61611ff58a73d9c791b564c691e0d2cbbdd86880 /dev-python/cliff
parentdev-python/osc-lib: Bump to 3.0.1 (diff)
downloadgentoo-38efbeadb26e5b24ef98cb2ffda0e3494a035dbd.tar.gz
gentoo-38efbeadb26e5b24ef98cb2ffda0e3494a035dbd.tar.bz2
gentoo-38efbeadb26e5b24ef98cb2ffda0e3494a035dbd.zip
dev-python/cliff: Bump to 4.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-4.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 9b04d77cc67d..de5749524af5 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-4.5.0.tar.gz 83722 BLAKE2B a610c65250cdf1ed33910408bdcde64a308c931d9e2c4d34d4b1b6e1c801354bf76833997b1672bf8b3cee54323da02baae479bf721a5ed507cfbc267c8c978d SHA512 e32f5c6f53a37306e79de79d3be653ea9fbe8581da6162578048f17188bb48d82a8108bd118cf34712601b08f53be80287c33929e07993c7363b09ad4f076d33
+DIST cliff-4.6.0.tar.gz 83765 BLAKE2B a71ec00ac4525b960da4b40135477a3ed3fab8651c12b69af1a48ef19ae6e2eec37c8ab8f83ab23e0a948b002a7bfb152b677fd0ec313deb5e70ee5cb37fdd46 SHA512 59e887eddbdf695927e9ece46749f3f62557fd20bb24d7ff109f174a4ae4886cb3b44994903522c1d31c83b9f7f101f16604f6ffc4167ed6405e49a09f236dd0
diff --git a/dev-python/cliff/cliff-4.6.0.ebuild b/dev-python/cliff/cliff-4.6.0.ebuild
new file mode 100644
index 000000000000..285b66c49d90
--- /dev/null
+++ b/dev-python/cliff/cliff-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest