summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-20 08:19:14 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-20 08:19:14 +0200
commitf04cf5971f448805856550c7fef6ddd620876108 (patch)
treecc4f6624eb801eaccb724821dbe02834c7321793 /dev-python/cons/cons-0.4.5.ebuild
parentdev-python/etuples: add 0.3.4 (diff)
downloadgentoo-f04cf5971f448805856550c7fef6ddd620876108.tar.gz
gentoo-f04cf5971f448805856550c7fef6ddd620876108.tar.bz2
gentoo-f04cf5971f448805856550c7fef6ddd620876108.zip
dev-python/cons: add 0.4.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cons/cons-0.4.5.ebuild')
-rw-r--r--dev-python/cons/cons-0.4.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/cons/cons-0.4.5.ebuild b/dev-python/cons/cons-0.4.5.ebuild
new file mode 100644
index 000000000000..bb4bc0818040
--- /dev/null
+++ b/dev-python/cons/cons-0.4.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of Lisp/Scheme-like cons in Python"
+HOMEPAGE="
+ https://pypi.org/project/cons/
+ https://github.com/pythological/python-cons/
+"
+SRC_URI="
+ https://github.com/pythological/python-cons/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="dev-python/logical-unification[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest