summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-03 19:07:31 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-03 19:14:40 -0800
commit4ebfc4044156e3ef2a5a735aa064b9c47679ca28 (patch)
tree6f74c91d72114649f362b1d250dbf03a480ef331 /dev-python/cookies/cookies-2.2.1-r1.ebuild
parentdev-python/testpath-0.4.4: version bump, add py38 (diff)
downloadgentoo-4ebfc4044156e3ef2a5a735aa064b9c47679ca28.tar.gz
gentoo-4ebfc4044156e3ef2a5a735aa064b9c47679ca28.tar.bz2
gentoo-4ebfc4044156e3ef2a5a735aa064b9c47679ca28.zip
dev-python/cookies-2.2.1-r1: revbump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/cookies/cookies-2.2.1-r1.ebuild')
-rw-r--r--dev-python/cookies/cookies-2.2.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/cookies/cookies-2.2.1-r1.ebuild b/dev-python/cookies/cookies-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..7902a8e44f21
--- /dev/null
+++ b/dev-python/cookies/cookies-2.2.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Friendlier RFC 6265-compliant cookie parser/renderer"
+HOMEPAGE="https://gitlab.com/sashahart/cookies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ # https://gitlab.com/sashahart/cookies/merge_requests/2
+ "${FILESDIR}/cookies-2.2.1-fix-warnings.patch"
+
+ "${FILESDIR}/cookies-2.2.1-tests.patch"
+)
+
+distutils_enable_tests pytest