summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-08 08:43:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-08 08:55:26 +0200
commit81b1e96786437ad341423ce642259eaecbba330f (patch)
tree4f703f134be572ebf627d48fcdce7509a07e2662 /dev-python/coreapi
parentdev-python/itypes: Bump to 1.2.0 (diff)
downloadgentoo-81b1e96786437ad341423ce642259eaecbba330f.tar.gz
gentoo-81b1e96786437ad341423ce642259eaecbba330f.tar.bz2
gentoo-81b1e96786437ad341423ce642259eaecbba330f.zip
dev-python/coreapi: Port to py3.10, enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coreapi')
-rw-r--r--dev-python/coreapi/Manifest2
-rw-r--r--dev-python/coreapi/coreapi-2.3.3-r1.ebuild17
2 files changed, 11 insertions, 8 deletions
diff --git a/dev-python/coreapi/Manifest b/dev-python/coreapi/Manifest
index bf4701165ff4..e04cc791180c 100644
--- a/dev-python/coreapi/Manifest
+++ b/dev-python/coreapi/Manifest
@@ -1 +1 @@
-DIST coreapi-2.3.3.tar.gz 18788 BLAKE2B f7837d6a0430e6617a2589aa84a209b3c544a913773bc4388c3bdef7348c83577e1b216e83c14736b15174ede840ae297b050eba551b4fe22d784e4d51677956 SHA512 5a66cf9613a9e11046577684b837f48e17db2285d14a51a77aa47eb945eef72a9ee0525b7b1b1c57fddec102c144ce56430ed5a95717e77d906d0b617dce708d
+DIST core-api-python-client-2.3.3.tar.gz 37470 BLAKE2B ce3f88e1608715eec06a50fa5df4cd331e90509d0b7e9ab275ccfb4b3b5216115539b7fcd70af64794f0ae50a5084873d2dbbd38c85cb8be3f319d6880f5993e SHA512 aeae3ace84c0ce61552236b83db28e47492f5ac17a0e216e1a8eeddaf67270b94127f7a40f8a37cc5051abe097555adfd690a7e6c8801524ca77c916bd451ab8
diff --git a/dev-python/coreapi/coreapi-2.3.3-r1.ebuild b/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
index 6b899647835f..f1d85bb66162 100644
--- a/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
+++ b/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
@@ -1,15 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
+MY_P=python-client-${PV}
DESCRIPTION="Python client library for Core API"
HOMEPAGE="https://github.com/core-api/python-client"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/core-api/python-client/archive/${PV}.tar.gz
+ -> core-api-${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
@@ -19,5 +22,5 @@ RDEPEND="dev-python/coreschema[${PYTHON_USEDEP}]
dev-python/itypes[${PYTHON_USEDEP}]
dev-python/uritemplate[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest