summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-16 21:29:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-16 21:50:04 +0300
commit26985cff13875b4bdc95bf98966b496992cc2680 (patch)
tree484c8135665ad50d6df0c5c9474ace69ac444b70 /dev-python/coverage
parentdev-python/sentry-sdk: add 1.9.5 (diff)
downloadgentoo-26985cff13875b4bdc95bf98966b496992cc2680.tar.gz
gentoo-26985cff13875b4bdc95bf98966b496992cc2680.tar.bz2
gentoo-26985cff13875b4bdc95bf98966b496992cc2680.zip
dev-python/coverage: add 6.4.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-6.4.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 3b4bba1fa575..bc47c0d8d0ba 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1 +1,2 @@
DIST coverage-6.4.3.tar.gz 722764 BLAKE2B f4d45aa9f0494bfe43e244907bda14e4a99bce7d4cdc4f6610abed3a2600a6f836dccd6c4c795f6bf0f8eeab2ab3df4f0ddc3f9e2d1285d57415f9bc06b47635 SHA512 7ff93dfb58f9d00a9016c86cc4425932c6dfc700954e5174b6a39c23900915f3dc1c5951a60d4ccb2155d82e2c552c07894670440dc17574e0ef5e0ba7bb4a81
+DIST coverage-6.4.4.tar.gz 772949 BLAKE2B 87b4c51ac43ac3bd2202496f6db6de5c74dd9925521bf3092cd862b86d8d7c0e3d008ee550c90e890febd87cc4d167669e830668f15da94ef4ea72e82154bf26 SHA512 f210f2471b170e05d4dac2cc9a91e3f0d4ba6456cdf91dc1c0ef67a02a11f4279c5beca5df8854c42660346995492b1eff020e1ac578d2a0a129627dadd17114
diff --git a/dev-python/coverage/coverage-6.4.4.ebuild b/dev-python/coverage/coverage-6.4.4.ebuild
new file mode 100644
index 000000000000..8a27c2c95f30
--- /dev/null
+++ b/dev-python/coverage/coverage-6.4.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/^addopts/s:-q -n auto::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_TEST_TRACER=${1}
+ einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
+ epytest tests
+}
+
+python_test() {
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" \
+ coverage/ || die
+ test_tracer c
+ rm coverage/*.so || die
+ else
+ test_tracer py
+ fi
+}