summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-31 08:23:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-31 08:52:54 +0100
commit0414ff37e6f2574731e160eca23de27765e10c87 (patch)
treee1269a006b5c210182556a1add849fa4134729b2 /dev-python/crispy-bootstrap5
parentdev-python/phonenumbers: Bump to 8.13.24 (diff)
downloadgentoo-0414ff37e6f2574731e160eca23de27765e10c87.tar.gz
gentoo-0414ff37e6f2574731e160eca23de27765e10c87.tar.bz2
gentoo-0414ff37e6f2574731e160eca23de27765e10c87.zip
dev-python/crispy-bootstrap5: Bump to 2023.10
Closes: https://bugs.gentoo.org/911699 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crispy-bootstrap5')
-rw-r--r--dev-python/crispy-bootstrap5/Manifest1
-rw-r--r--dev-python/crispy-bootstrap5/crispy-bootstrap5-2023.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap5/Manifest b/dev-python/crispy-bootstrap5/Manifest
index f709b3c7df14..843a1e5d3e3d 100644
--- a/dev-python/crispy-bootstrap5/Manifest
+++ b/dev-python/crispy-bootstrap5/Manifest
@@ -1 +1,2 @@
DIST crispy-bootstrap5-0.7.gh.tar.gz 29728 BLAKE2B 1209ab7d8340e30c71050ed60a86d8233f454c49d2f6d4fcf4f1d6be4a7d1c470c3f907211c1ee352fc3eba9a74e8152d41162e4d6f8113538eccbb3522409a5 SHA512 c73305c6661719cd45989679c33751f44b318b39f895e0328257eaffcdd52b726be9be624ebecb6bcba35635f0f615bb83e48c775e0f05c40f8f1e6e80ab737c
+DIST crispy-bootstrap5-2023.10.gh.tar.gz 31222 BLAKE2B cab972ed222ba0245d0a0d6e75487aac03c054f8669859fc4eb8293c2abb3775ef76f6866402917d1d1bfa0444548983639a24bd5fd4d1c2a3bbd74d1c086057 SHA512 379e4ea536809ceeb347d8894953acd97362c7340cb496727e4f56c2967aba93b1b041166ba6b8253d4952e4fa97f80668041733ddbd2ca62b60f4f9046259ef
diff --git a/dev-python/crispy-bootstrap5/crispy-bootstrap5-2023.10.ebuild b/dev-python/crispy-bootstrap5/crispy-bootstrap5-2023.10.ebuild
new file mode 100644
index 000000000000..b21a1f0b456f
--- /dev/null
+++ b/dev-python/crispy-bootstrap5/crispy-bootstrap5-2023.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap5 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/
+ https://pypi.org/project/crispy-bootstrap5/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-crispy-forms-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest