summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-09 14:49:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-09 15:08:14 +0200
commit4a3f6b5abf3ecc1e2309fb9320c208cde0de0f63 (patch)
treed175202771eb4522f0c3c1e0129545a5beac1c8d /dev-python/deprecation
parentdev-python/deprecation: Port to py3.9 (diff)
downloadgentoo-4a3f6b5abf3ecc1e2309fb9320c208cde0de0f63.tar.gz
gentoo-4a3f6b5abf3ecc1e2309fb9320c208cde0de0f63.tar.bz2
gentoo-4a3f6b5abf3ecc1e2309fb9320c208cde0de0f63.zip
dev-python/deprecation: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecation')
-rw-r--r--dev-python/deprecation/Manifest1
-rw-r--r--dev-python/deprecation/deprecation-2.1.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/deprecation/Manifest b/dev-python/deprecation/Manifest
index c9974089d590..e223da814293 100644
--- a/dev-python/deprecation/Manifest
+++ b/dev-python/deprecation/Manifest
@@ -1 +1,2 @@
DIST deprecation-2.0.7.tar.gz 17077 BLAKE2B da3fb5db53f281c29e2af40335ef4038e37d133563b85d0ea795a314fd9f2d725a98c100aca338dc9ebe60bb1000476e0debcfdc9c4583108004df207cb36747 SHA512 4412e2e95f4aa4b3d5598346a6649c8d945d7401ac2d0fba3b6f6eef567403c8454ebe537e8de646903cd0c2308f48ecb949dae3015ba7617edd2fa3a26ed429
+DIST deprecation-2.1.0.tar.gz 173788 BLAKE2B 444c7ff688d6eab7dfcf58ad24580b5a6df39a5749341b28d6d5b9b516fd6aa7a462d7f644e6cba596bbf289be0224968f579837c6c71dbe7b36b65588da6eea SHA512 c184665d210c6eeb3f055b23e75c3714f3b18050e03bfe1384baf6c2504f1370116ae0e8c53ff818ccc54c0d633bbb3ba5791fe20b8029f3be0207b019a00275
diff --git a/dev-python/deprecation/deprecation-2.1.0.ebuild b/dev-python/deprecation/deprecation-2.1.0.ebuild
new file mode 100644
index 000000000000..e5d8d60b80da
--- /dev/null
+++ b/dev-python/deprecation/deprecation-2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to handle automated deprecations"
+HOMEPAGE="https://deprecation.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest