summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-24 22:44:48 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-25 00:32:48 +0200
commit7cd7e12629de625a0ffff33261d5d8d178a8dd16 (patch)
tree9374bfea8bc774df9c109c0ce62e9f16c0b65ab6 /dev-python/dissononce
parentdev-python/dissononce: add python3.9 support (diff)
downloadgentoo-7cd7e12629de625a0ffff33261d5d8d178a8dd16.tar.gz
gentoo-7cd7e12629de625a0ffff33261d5d8d178a8dd16.tar.bz2
gentoo-7cd7e12629de625a0ffff33261d5d8d178a8dd16.zip
dev-python/dissononce: drop old version
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/dissononce')
-rw-r--r--dev-python/dissononce/dissononce-0.34.3.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/dissononce/dissononce-0.34.3.ebuild b/dev-python/dissononce/dissononce-0.34.3.ebuild
deleted file mode 100644
index ba5c872c5ff7..000000000000
--- a/dev-python/dissononce/dissononce-0.34.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="A python implementation for Noise Protocol Framework"
-HOMEPAGE="https://github.com/tgalal/dissononce"
-SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples test"
-
-# Currently no tests are available,
-# they will be added in future by upstream.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/transitions[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- ${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}/${P}-fix-test-requirements.patch" )
-
-python_test() {
- esetup.py test
-}
-
-src_install() {
- distutils-r1_src_install
-
- use examples && dodoc examples/patterns/*.py
-}