summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-12 15:30:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-12 15:30:40 +0100
commit10541f379007b902cd8c7c25f1ecc2c492c19c9f (patch)
tree275e0690e34e9dd9d1c8b9c9e16496014806cf45 /dev-python/dj-database-url
parentdev-cpp/rapidfuzz-cpp: Remove old (diff)
downloadgentoo-10541f379007b902cd8c7c25f1ecc2c492c19c9f.tar.gz
gentoo-10541f379007b902cd8c7c25f1ecc2c492c19c9f.tar.bz2
gentoo-10541f379007b902cd8c7c25f1ecc2c492c19c9f.zip
dev-python/dj-database-url: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dj-database-url')
-rw-r--r--dev-python/dj-database-url/Manifest1
-rw-r--r--dev-python/dj-database-url/dj-database-url-1.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/Manifest b/dev-python/dj-database-url/Manifest
index 8b45c451405d..c509d39cdb43 100644
--- a/dev-python/dj-database-url/Manifest
+++ b/dev-python/dj-database-url/Manifest
@@ -1 +1,2 @@
DIST dj-database-url-1.0.0.gh.tar.gz 11355 BLAKE2B 9ea50eb2646367333556133020a59f332cb69e05fb392f328558f77cb03ffa968cf62241f3823e28600799a1399ac1335b90477a26a4931b0df7b695b502e9be SHA512 35ca0c05910812e10bf63b061afb434ac7c562e3d994b6e452250fe4ec95983fe8353aec0df9c7638a990684e612863ddada5be48485a1db3120e110f6d0fa94
+DIST dj-database-url-1.1.0.gh.tar.gz 12095 BLAKE2B 61d32e20ce06451300474f88debb12e960ea6efce8706d6f61991eb204cc8be62f40f38272d9ef177dfa6f4f8a7502c38d17e4c2b01ccb2b256b1dc5329c8dd7 SHA512 4c2ee396daf1a8052a981f8b8df1ba02405020bd4ce3e36df0e34d8be745e5b71a5eb7fef8fc7bff05a8846e9aa1d29857d71e9ba7aa2b5ac0fcb9fabc9f0e60
diff --git a/dev-python/dj-database-url/dj-database-url-1.1.0.ebuild b/dev-python/dj-database-url/dj-database-url-1.1.0.ebuild
new file mode 100644
index 000000000000..c30f6849ca02
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="
+ https://github.com/jazzband/dj-database-url/
+ https://pypi.org/project/dj-database-url/
+"
+SRC_URI="
+ https://github.com/jazzband/dj-database-url/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest