summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-07-11 17:18:36 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-07-11 17:19:27 -0500
commit3bf1a1743b3910e3e055d54aa78564e5263488e7 (patch)
tree62e0b4595e1d4290d79a12be9937c5f177666754 /dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild
parentdev-python/django-cors-headers: 3.0.2 bump (diff)
downloadgentoo-3bf1a1743b3910e3e055d54aa78564e5263488e7.tar.gz
gentoo-3bf1a1743b3910e3e055d54aa78564e5263488e7.tar.bz2
gentoo-3bf1a1743b3910e3e055d54aa78564e5263488e7.zip
dev-python/django-debug-toolbar: 2.0 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild')
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild
new file mode 100644
index 000000000000..fe591fca5ade
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/django-debug-toolbar/django-debug-toolbar/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.0[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # Prevent non essential d'loading by intersphinx
+ sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+
+ # This prevents distutils from installing 'tests' package, rm magic no more needed
+ sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}