summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-tables2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-tables2')
-rw-r--r--dev-python/django-tables2/Manifest2
-rw-r--r--dev-python/django-tables2/django-tables2-0.16.0-r1.ebuild25
-rw-r--r--dev-python/django-tables2/django-tables2-0.16.0.ebuild23
-rw-r--r--dev-python/django-tables2/django-tables2-1.0.4.ebuild23
-rw-r--r--dev-python/django-tables2/files/django-tables2-0.16.0-django-1.9-deprecation.patch118
-rw-r--r--dev-python/django-tables2/metadata.xml13
6 files changed, 204 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
new file mode 100644
index 000000000000..9c45f7e2e6e7
--- /dev/null
+++ b/dev-python/django-tables2/Manifest
@@ -0,0 +1,2 @@
+DIST django-tables2-0.16.0.tar.gz 43672 SHA256 53a643166377c44a030d860f3c0f045c4b75e727432ddde4065a67c2df41bf33 SHA512 9d490bbcaab6049d74e81f25c0a2e1ebd3caa00930877661cc823dcfc429f020b3146ec778ccc840951e89f53047e8d6ad71cf7b689cfb76aa2eadf5db54280a WHIRLPOOL 907acbfb5599589ebf5dc49ebedd0f9e07003df7730a5bcc04667207140d9728fbed56afc08ed25167414bc4596a91e2106958223f5c48b5ccea2c6642b0365e
+DIST django-tables2-1.0.4.tar.gz 57679 SHA256 801b1df349f07f5b548cf4b3d5cddfc26e5969079c7d490f179fb649e76d24af SHA512 ae1381ab23b93759caef259b5063c2149a71c9a808bc4f0a621de454872b354d03e8d7002a95de693e4d3c456366341ac30f200edac069244a0b97d156295953 WHIRLPOOL 03cfd673a16692de118b4eafb7a3fec277daef4045d16508c9a97abcdf2321782703fb4e12b9f26e7fddf799e1d8040028f43a0584f4bdc59f481c504f21586f
diff --git a/dev-python/django-tables2/django-tables2-0.16.0-r1.ebuild b/dev-python/django-tables2/django-tables2-0.16.0-r1.ebuild
new file mode 100644
index 000000000000..d4992a761e16
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-0.16.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="https://pypi.python.org/pypi/django-tables2/ https://github.com/bradleyayers/django-tables2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/${P}-django-1.9-deprecation.patch )
diff --git a/dev-python/django-tables2/django-tables2-0.16.0.ebuild b/dev-python/django-tables2/django-tables2-0.16.0.ebuild
new file mode 100644
index 000000000000..2f19150eb0db
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="https://pypi.python.org/pypi/django-tables2/ https://github.com/bradleyayers/django-tables2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/django-tables2/django-tables2-1.0.4.ebuild b/dev-python/django-tables2/django-tables2-1.0.4.ebuild
new file mode 100644
index 000000000000..2f19150eb0db
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-1.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="https://pypi.python.org/pypi/django-tables2/ https://github.com/bradleyayers/django-tables2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/django-tables2/files/django-tables2-0.16.0-django-1.9-deprecation.patch b/dev-python/django-tables2/files/django-tables2-0.16.0-django-1.9-deprecation.patch
new file mode 100644
index 000000000000..12460d4ffbdb
--- /dev/null
+++ b/dev-python/django-tables2/files/django-tables2-0.16.0-django-1.9-deprecation.patch
@@ -0,0 +1,118 @@
+From cb71f869bbc8aac3a14f3d4d1f67641e21892bba Mon Sep 17 00:00:00 2001
+From: Gert Steyn <gert@senseware.com>
+Date: Thu, 19 Mar 2015 12:20:42 +0200
+Subject: [PATCH] Changed from django.utils.datastructures.SortedDict
+ (deprecated) to collections.OrderedDict
+
+---
+ django_tables2/columns/base.py | 6 +++---
+ django_tables2/tables.py | 10 +++++-----
+ django_tables2/templatetags/django_tables2.py | 4 ++--
+ 3 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/django_tables2/columns/base.py b/django_tables2/columns/base.py
+index 20b3477..3b377e6 100644
+--- a/django_tables2/columns/base.py
++++ b/django_tables2/columns/base.py
+@@ -1,9 +1,9 @@
+ # coding: utf-8
+ from __future__ import absolute_import, unicode_literals
+ from django.db.models.fields import FieldDoesNotExist
+-from django.utils.datastructures import SortedDict
+ from django_tables2.templatetags.django_tables2 import title
+ from django_tables2.utils import A, AttributeDict, OrderBy, OrderByTuple
++from collections import OrderedDict
+ from itertools import islice
+ import six
+ import warnings
+@@ -498,7 +498,7 @@ class BoundColumns(object):
+ A `BoundColumns` object is a container for holding `BoundColumn` objects.
+ It provides methods that make accessing columns easier than if they were
+ stored in a `list` or `dict`. `Columns` has a similar API to a `dict` (it
+- actually uses a `~django.utils.datastructures.SortedDict` interally).
++ actually uses a `~collections.OrderedDict` interally).
+
+ At the moment you'll only come across this class when you access a
+ `.Table.columns` property.
+@@ -508,7 +508,7 @@ class BoundColumns(object):
+ """
+ def __init__(self, table):
+ self.table = table
+- self.columns = SortedDict()
++ self.columns = OrderedDict()
+ for name, column in six.iteritems(table.base_columns):
+ self.columns[name] = bc = BoundColumn(table, column, name)
+ bc.render = getattr(table, 'render_' + name, column.render)
+diff --git a/django_tables2/tables.py b/django_tables2/tables.py
+index 01a0671..2f31069 100644
+--- a/django_tables2/tables.py
++++ b/django_tables2/tables.py
+@@ -9,9 +9,9 @@
+ import sys
+ from django.core.paginator import Paginator
+ from django.db.models.fields import FieldDoesNotExist
+-from django.utils.datastructures import SortedDict
+ from django.template import RequestContext
+ from django.template.loader import get_template
++from collections import OrderedDict
+ import six
+ import warnings
+
+@@ -172,10 +172,10 @@ def __new__(mcs, name, bases, attrs):
+ if hasattr(base, "base_columns"):
+ parent_columns = list(base.base_columns.items()) + parent_columns
+ # Start with the parent columns
+- attrs["base_columns"] = SortedDict(parent_columns)
++ attrs["base_columns"] = OrderedDict(parent_columns)
+ # Possibly add some generated columns based on a model
+ if opts.model:
+- extra = SortedDict()
++ extra = OrderedDict()
+ # honor Table.Meta.fields, fallback to model._meta.fields
+ if opts.fields:
+ # Each item in opts.fields is the name of a model field or a
+@@ -194,7 +194,7 @@ def __new__(mcs, name, bases, attrs):
+ attrs["base_columns"].update(extra)
+
+ # Explicit columns override both parent and generated columns
+- attrs["base_columns"].update(SortedDict(cols))
++ attrs["base_columns"].update(OrderedDict(cols))
+ # Apply any explicit exclude setting
+ for exclusion in opts.exclude:
+ if exclusion in attrs["base_columns"]:
+@@ -204,7 +204,7 @@ def __new__(mcs, name, bases, attrs):
+ opts.sequence.expand(attrs["base_columns"].keys())
+ # Table's sequence defaults to sequence declared in Meta
+ #attrs['_sequence'] = opts.sequence
+- attrs["base_columns"] = SortedDict(((x, attrs["base_columns"][x]) for x in opts.sequence))
++ attrs["base_columns"] = OrderedDict(((x, attrs["base_columns"][x]) for x in opts.sequence))
+
+ # set localize on columns
+ for col_name in attrs["base_columns"].keys():
+diff --git a/django_tables2/templatetags/django_tables2.py b/django_tables2/templatetags/django_tables2.py
+index 1e72d74..1ca91de 100644
+--- a/django_tables2/templatetags/django_tables2.py
++++ b/django_tables2/templatetags/django_tables2.py
+@@ -5,12 +5,12 @@
+ from django.template import TemplateSyntaxError, Variable, Node
+ from django.template.loader import get_template, select_template
+ from django.template.defaultfilters import stringfilter, title as old_title
+-from django.utils.datastructures import SortedDict
+ from django.utils.http import urlencode
+ from django.utils.html import escape
+ from django.utils.safestring import mark_safe
+ import django_tables2 as tables
+ from django_tables2.config import RequestConfig
++from collections import OrderedDict
+ import re
+ import six
+ import tokenize
+@@ -35,7 +35,7 @@ def token_kwargs(bits, parser):
+ """
+ if not bits:
+ return {}
+- kwargs = SortedDict()
++ kwargs = OrderedDict()
+ while bits:
+ match = kwarg_re.match(bits[0])
+ if not match or not match.group(1):
diff --git a/dev-python/django-tables2/metadata.xml b/dev-python/django-tables2/metadata.xml
new file mode 100644
index 000000000000..a09809c9ef44
--- /dev/null
+++ b/dev-python/django-tables2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-tables2</remote-id>
+ <remote-id type="github">bradleyayers/django-tables2</remote-id>
+ </upstream>
+</pkgmetadata>