summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 09:36:42 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 11:06:44 +0100
commitf4e0f553b0b53abf834bd11cd967ae947d325168 (patch)
tree75c21070dab5be05d35a9118c8eff52e73913ce7 /dev-python/django
parentdev-python/django: Bump to 3.2.12 (diff)
downloadgentoo-f4e0f553b0b53abf834bd11cd967ae947d325168.tar.gz
gentoo-f4e0f553b0b53abf834bd11cd967ae947d325168.tar.bz2
gentoo-f4e0f553b0b53abf834bd11cd967ae947d325168.zip
dev-python/django: Bump to 2.2.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/Manifest2
-rw-r--r--dev-python/django/django-2.2.27.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index 7572b2471c9f..db183c7584a1 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -1,5 +1,7 @@
DIST Django-2.2.26.checksum.txt 2561 BLAKE2B a974c7d5c8cef76e781e4fa1559725cc7d77de3d16b08ec20d034b38cb39a986b62397532bbc81d4414b3eae8a5487a9fef9615eed73946a54a2b43cdf34a6ad SHA512 7c1d3e04913237ed0dc9955eedd02cfb5113b9536ed0b471d873269ec82099561714a061b74bf212c2e99bbe47e6cf72e639358a2f9134f751fdd7cd53e6ce17
DIST Django-2.2.26.tar.gz 9207984 BLAKE2B abd520bc5681b8450e51c4248eb97558daa6a87f74915bea8857843a5ea9be6bf3a04c9f5871c35d2076adb644da266c7b88ac39bb2837ff1eaa71f885bd08bf SHA512 2005b081e7347f6f8fd4837219043bd1728cd85aca00c62a16432f63272abec7d30b7461675708fa0f55e3273af5bbd67c26d31934f8a4a38f48e65ea721916f
+DIST Django-2.2.27.checksum.txt 2556 BLAKE2B 770dc5670d0d4aebcfd1956d644b9d7e4e5bf0b511649ae072de1b8ec8d2ea12dbc48563f5372979dead9e729abd9b5174c99323a14170876b1f1b5e61de96f6 SHA512 fb76f2bef6e6d0a3002298e4eeec5b335bfdc365ae55f0c26dcb050d369864c504dd32d40ac3b49897d56bc0dadc10136b588361ddf3598ffdc03830a97e1d63
+DIST Django-2.2.27.tar.gz 9185716 BLAKE2B 26d509c722c62b5bf784331466a97ad1b961715572da9e6add4be1bdc7cf999c0ec7c763d9bc8ab2fc1ca35a48783feaf748c3c9388ae9f5f3e393972deea734 SHA512 0db670651a820b49d855e38a336c0c6990ce4701bb686c5e8a292ccb03342e995c61c2c628b1d625d2715404e969fc31c256e5bf0fd6c1ff714d1c1c1ee30bff
DIST Django-3.2.11.checksum.txt 2561 BLAKE2B ece4f40d4d368e2e5ad3cc3ed6072aa8d1693b47d68b76020059508bfc10a30f6291f5e84c68bb959fa973c4e060bf4fd408beefaedc13b68e81b721cb78aab3 SHA512 4f2c12088cfb69f547ba687e9cac34b68a9bd28c793482430bda078f51e780b1272de7ec7816dc31d2fa93bf1c68973f847d67c01414fc8bf07fa6f6ea09dc39
DIST Django-3.2.11.tar.gz 9821958 BLAKE2B 8f83db578e31c3cbeca67bd826b4c639b346e449de83aba6ddf6bf4eef1fc58ebcbbddf91227012e592516d7796d9f3cc468ae4ce51d684b4aa0a417bb39ddb1 SHA512 ea1ca9a76afcd7e20d0ce518efc0497bbd11f4ab7ed20bd4490561bfcfc6c80db8922a22d8aca94c1dc2743e7366b28a0ae76c3d64f55afc142c38a744dd5120
DIST Django-3.2.12.checksum.txt 2556 BLAKE2B 7ae6e41305b5b07969ddad3474a0819359dff888fc3bdc1c5000ded1b9b726a7c55aa7aaffc85184558edcc6c12b617c8270cc569fa8e645622206631979a9c2 SHA512 5098dde440a15ad066fa7927943f4ec66bb925798afcb42101c5cf50b8148301866c39ad37ebb5db9d7f9e195953337c03dc6fa2c49758716f969ee2ce414d24
diff --git a/dev-python/django/django-2.2.27.ebuild b/dev-python/django/django-2.2.27.ebuild
new file mode 100644
index 000000000000..9fc3644a1ce4
--- /dev/null
+++ b/dev-python/django/django-2.2.27.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 optfeature verify-sig
+
+MY_P=${P^}
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
+SRC_URI="
+ https://media.djangoproject.com/releases/$(ver_cut 1-2)/${MY_P}.tar.gz
+ verify-sig? ( https://media.djangoproject.com/pgp/${MY_P}.checksum.txt )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc sqlite test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ )
+ verify-sig? ( sec-keys/openpgp-keys-django )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
+)
+
+distutils_enable_sphinx docs --no-autodoc
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/django.asc
+
+src_unpack() {
+ if use verify-sig; then
+ cd "${DISTDIR}" || die
+ verify-sig_verify_signed_checksums \
+ "${MY_P}.checksum.txt" sha256 "${MY_P}.tar.gz"
+ cd "${WORKDIR}" || die
+ fi
+
+ default
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite -v2 ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature_header "Additional Backend support can be enabled via:"
+ optfeature "MySQL backend support" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:2
+ optfeature_header
+ optfeature "GEO Django" "sci-libs/gdal[geos]"
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+ optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+}