summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-19 05:34:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-19 05:51:07 +0200
commit0202cf5eb00aba11ace95f6ed8fe0d1a5f01a1df (patch)
tree8eed89c1589a60b5f5039ab1f2c0351883256765 /dev-python/dns-lexicon
parentdev-python/GitPython: Bump to 3.1.40 (diff)
downloadgentoo-0202cf5eb00aba11ace95f6ed8fe0d1a5f01a1df.tar.gz
gentoo-0202cf5eb00aba11ace95f6ed8fe0d1a5f01a1df.tar.bz2
gentoo-0202cf5eb00aba11ace95f6ed8fe0d1a5f01a1df.zip
dev-python/dns-lexicon: Bump to 3.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest1
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index 7db9ccb056f4..e8eda7675d0c 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -4,3 +4,4 @@ DIST dns-lexicon-3.14.1.gh.tar.gz 6747567 BLAKE2B 55ddba2caf71b92ad0e5f34457d33c
DIST dns-lexicon-3.15.0.gh.tar.gz 6200937 BLAKE2B 94ff86424e5f9d03d5ec059359f684cbcda8fd617f84510c7154c2f48072b766bab0497ef1dd46c630b25f8196d177715eeaa9223bf2b502f125526120f91327 SHA512 22e6f11e2b5750ff44c8a72b0e6c0a1a4126e247074b87cf7fbbf403d8858c261fb2c57a5d01daa218e4b3448782ccb5567fd6f29da78baabb2aded90a82c97c
DIST dns-lexicon-3.15.1.gh.tar.gz 6201895 BLAKE2B 85279f48b55bc4fac4017874728bdb089ec120105051119c229892335bead4cd2c2ee8a3a2527ca43e23e3c103bc3d0fbf3eef2f26681de0f8d07b0de10cc3eb SHA512 406a88808e0200cdd8e510e4a99688b75e3333be306b209931bd3282d9cd80fca15cf0b50a537d208f4b41cc6022e8501de6fbe83e20b426a8dc28724cd92fb8
DIST dns-lexicon-3.16.0.gh.tar.gz 6198018 BLAKE2B fcba99b0e1e93cf585043c58d0b7c3efa972976c8ac9db491a0081c46adad7720f0039cbb4f10af3c72ee8bf83cbb549fb6f3f511e0774161562b899fdc425b6 SHA512 1de871ab54b0f4a40f5c634f69d4c73b4233ca37f740710d78f2b2b298f972b93992bd44adf64d36dfa2fdfefc0cf25a862066ad391be695c403388c5cbb9c22
+DIST dns-lexicon-3.16.1.gh.tar.gz 6199830 BLAKE2B 0965fbb325232e7d0f8cc5f0eb34eb8821b42de4aa16e7e96adb8bd88e329756768347a3a174daeccac6d4576f7b88f252516a4b3a416c0be23b4ec78525e472 SHA512 7cf2392ec94871076f13e443a6f8c1e9486ceed44c7a23f28e29a98ad0ee8b5f3ae534d3627b4f04fc77894059a2f8a49b12bae3f6faa52a4cbd175bd6cd6e99
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild
new file mode 100644
index 000000000000..55e62bd2d181
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pyotp-2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/boto3-1.25[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ tests/providers/test_transip.py
+ # Requires the "oci" module
+ tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ tests/providers/test_auto.py
+ # All recordings seem to be broken
+ tests/providers/test_namecheap.py
+ # Broken by minor vcrpy / urllib3-2 incompatibility
+ # https://github.com/kevin1024/vcrpy/issues/714
+ tests/providers/test_route53.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}