summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 21:13:29 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 21:13:29 +0200
commitcb0c2f54ecbfc25c71dfd4f084103dd29b866e8e (patch)
tree108519f204d4b498225b68a467ebddd17796de8c /dev-python/dnspython
parentdev-python/pydevd: add 2.8.0 (diff)
downloadgentoo-cb0c2f54ecbfc25c71dfd4f084103dd29b866e8e.tar.gz
gentoo-cb0c2f54ecbfc25c71dfd4f084103dd29b866e8e.tar.bz2
gentoo-cb0c2f54ecbfc25c71dfd4f084103dd29b866e8e.zip
dev-python/dnspython: add 2.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-2.2.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index baf8018efefa..e9b8c2585aaf 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1 +1,2 @@
DIST dnspython-2.2.0.tar.gz 303844 BLAKE2B 5a99a06d1c7e8f29e44ddc99fed11d772d83d962d7abde61befb3189c6faa2796b239e9c0ec05a453360986ff4bbbcea929f62017eb3bab2bafa517ae4c02a3b SHA512 0a93bde1ca1081c92b9fb5a02644c4920813f2d0dbe4de1dae736262d53afe41327f3fdd38a10f74ec78f54dd7c7570e37d0adb2b21ab18f9b5cc099fcc6bb85
+DIST dnspython-2.2.1.tar.gz 304861 BLAKE2B e6446b91579c6ec0a7266a354ceb58e2f881b55b7376648770ebc2c6104fd815214497516d305b75802e9211703d47a70d66745d872a43afb72f41e55a617652 SHA512 ec545468f604d6131f07259ca154c4f71d445d12c336ac1da0d2f025d6478ada76320a7235119312fed85da071ef309d2531e541d3c2340a50deaf3f4dd7b4eb
diff --git a/dev-python/dnspython/dnspython-2.2.1.ebuild b/dev-python/dnspython/dnspython-2.2.1.ebuild
new file mode 100644
index 000000000000..10b72b9da4d7
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="https://www.dnspython.org/
+ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ <dev-python/idna-4.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -s
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}