summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-17 20:00:10 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-17 20:00:18 +0200
commit5f205159626967f3d87952a22fb63c7ca9256cbe (patch)
tree6846ea2434ab599f2cb035020cfe8a5d4c4e49dc /dev-python/ensurepip-pip
parentapp-editors/vscodium: add 1.85.1.23348 (diff)
downloadgentoo-5f205159626967f3d87952a22fb63c7ca9256cbe.tar.gz
gentoo-5f205159626967f3d87952a22fb63c7ca9256cbe.tar.bz2
gentoo-5f205159626967f3d87952a22fb63c7ca9256cbe.zip
dev-python/ensurepip-pip: add 23.3.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ensurepip-pip')
-rw-r--r--dev-python/ensurepip-pip/Manifest1
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-23.3.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ensurepip-pip/Manifest b/dev-python/ensurepip-pip/Manifest
index 92c4bb6040e9..2fd7ff5f1311 100644
--- a/dev-python/ensurepip-pip/Manifest
+++ b/dev-python/ensurepip-pip/Manifest
@@ -1 +1,2 @@
DIST pip-23.3.1-py3-none-any.whl 2107242 BLAKE2B d5ea7ead01468f1f6a5c60811de9410d260e820638c0073f70e480dd3678e7413ae612913c01456779d391a6108ce939eced95392696eb5b1cc26b3a7a04a99d SHA512 1a60d153982c1c5997d3826f4084b39ec4054228376093ee15c1f4be0781e78c4b1e5219b5f05cdc464588dec379f9f2cc21f075aa0a11a148d3545a547b9889
+DIST pip-23.3.2-py3-none-any.whl 2109393 BLAKE2B 278b9941f93951508ae2f508b1b5a9fddd4ca11fac1d5b0c2ac994f8e8457226a4e8c4501078776476e0bae56fd82b989ebaf4f5f484ffe7b0ee79789e34aca8 SHA512 a1449fe400787f73ac26cb48acaae71208a2e696f9ce4992b44e11da29646b018c2f6c27a95b12e42531236fe658e0605e20d5dfa740c43e005c01da3db802da
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-23.3.2.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-23.3.2.ebuild
new file mode 100644
index 000000000000..474a502c1273
--- /dev/null
+++ b/dev-python/ensurepip-pip/ensurepip-pip-23.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared pip wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/pip/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}