summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-09 14:00:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-09 14:22:11 +0200
commite5e9a8d36dba3340831ae9ff71757f8413bb55ae (patch)
tree8601f6db97b3572c157383ef6f3eea43ac378c53 /dev-python/eradicate/eradicate-2.3.0.ebuild
parentdev-python/hypothesis: Bump to 6.77.0 (diff)
downloadgentoo-e5e9a8d36dba3340831ae9ff71757f8413bb55ae.tar.gz
gentoo-e5e9a8d36dba3340831ae9ff71757f8413bb55ae.tar.bz2
gentoo-e5e9a8d36dba3340831ae9ff71757f8413bb55ae.zip
dev-python/eradicate: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/eradicate/eradicate-2.3.0.ebuild')
-rw-r--r--dev-python/eradicate/eradicate-2.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/eradicate/eradicate-2.3.0.ebuild b/dev-python/eradicate/eradicate-2.3.0.ebuild
new file mode 100644
index 000000000000..0ee0a07f33fc
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="
+ https://github.com/wemake-services/eradicate/
+ https://pypi.org/project/eradicate/
+"
+SRC_URI="
+ https://github.com/wemake-services/eradicate/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest