summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-26 12:53:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-26 13:10:05 +0200
commit48af05f91744265fcafd51b805e9dca1a478af64 (patch)
tree30f96837bdc118907cd34bfdb629c444a9da0571 /dev-python/executing/executing-1.1.0.ebuild
parentdev-python/stack_data: Bump to 0.5.1 (diff)
downloadgentoo-48af05f91744265fcafd51b805e9dca1a478af64.tar.gz
gentoo-48af05f91744265fcafd51b805e9dca1a478af64.tar.bz2
gentoo-48af05f91744265fcafd51b805e9dca1a478af64.zip
dev-python/executing: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/executing/executing-1.1.0.ebuild')
-rw-r--r--dev-python/executing/executing-1.1.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/executing/executing-1.1.0.ebuild b/dev-python/executing/executing-1.1.0.ebuild
new file mode 100644
index 000000000000..26b7519766f7
--- /dev/null
+++ b/dev-python/executing/executing-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/
+"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/littleutils[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ epytest tests/test_pytest.py
+}