summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 15:12:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 15:15:35 +0100
commit5e18e4807dd3ed7278500072fbe4c5e20e7f58d0 (patch)
tree3829ee32dd48ca39351160f564b0f0f681b7d7fd /dev-python/expects
parentdev-python/mamba: py3.11, PEP517 (diff)
downloadgentoo-5e18e4807dd3ed7278500072fbe4c5e20e7f58d0.tar.gz
gentoo-5e18e4807dd3ed7278500072fbe4c5e20e7f58d0.tar.bz2
gentoo-5e18e4807dd3ed7278500072fbe4c5e20e7f58d0.zip
dev-python/expects: EAPI 8, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/expects')
-rw-r--r--dev-python/expects/expects-0.9.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/expects/expects-0.9.0-r1.ebuild b/dev-python/expects/expects-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..dbd903d624a0
--- /dev/null
+++ b/dev-python/expects/expects-0.9.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
+HOMEPAGE="
+ https://github.com/jaimegildesagredo/expects/
+ https://pypi.org/project/expects/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/mamba[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ mamba || die "tests failed under ${EPYTHON}"
+}