summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-02-06 18:02:54 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-02-06 18:54:21 -0600
commit1e40740df2b45fc69b9247554c8e1cd1b9531d36 (patch)
tree6d9415d2dd0bcbc2ea505c5366a2b56cc3971892 /dev-python/faulthandler/faulthandler-3.0.ebuild
parentapp-doc/doxygen: update live ebuild (diff)
downloadgentoo-1e40740df2b45fc69b9247554c8e1cd1b9531d36.tar.gz
gentoo-1e40740df2b45fc69b9247554c8e1cd1b9531d36.tar.bz2
gentoo-1e40740df2b45fc69b9247554c8e1cd1b9531d36.zip
dev-python/faulthandler: version bump to 3.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/faulthandler/faulthandler-3.0.ebuild')
-rw-r--r--dev-python/faulthandler/faulthandler-3.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/faulthandler/faulthandler-3.0.ebuild b/dev-python/faulthandler/faulthandler-3.0.ebuild
new file mode 100644
index 000000000000..d996088ebc96
--- /dev/null
+++ b/dev-python/faulthandler/faulthandler-3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="functions to dump Python tracebacks explicitly (on fault, user signal, timeout)"
+HOMEPAGE="https://github.com/haypo/faulthandler https://pypi.python.org/pypi/faulthandler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""