summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-26 19:23:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-26 19:23:00 +0200
commit06fc887469640639046a96da5266e0c835bb31ef (patch)
treec4df83a79b62cb683993ef96a0b7c15fad8b5950 /dev-python/fixtures
parentdev-python/license-expression: Enable py3.12 (diff)
downloadgentoo-06fc887469640639046a96da5266e0c835bb31ef.tar.gz
gentoo-06fc887469640639046a96da5266e0c835bb31ef.tar.bz2
gentoo-06fc887469640639046a96da5266e0c835bb31ef.zip
dev-python/fixtures: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/Manifest1
-rw-r--r--dev-python/fixtures/fixtures-4.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/fixtures/Manifest b/dev-python/fixtures/Manifest
index d4647ca4ae0e..6795e133d7ce 100644
--- a/dev-python/fixtures/Manifest
+++ b/dev-python/fixtures/Manifest
@@ -1 +1,2 @@
DIST fixtures-4.0.1.tar.gz 56752 BLAKE2B bddda3976ec453129fa05e53da066344ed8f4db9626ec21dd0159e6720993da0c17e3b51ba37de2ef05cd7649809d674cc6409b16c8e1d242dc424d573010975 SHA512 722436f146768e4db1e3312a0db1edab2a7daa86107825fb2436654eaf74e00f569357531316df506ef3f80cef89ac7185aee1adf0b00a6ee85cbc9811ca8100
+DIST fixtures-4.1.0.tar.gz 58561 BLAKE2B fc88ee580806e289d3d4a8a35701b0b17ee48bc157dbb355035ac0fb1bde64bdbf3596d54538e6032c74f8862a36fea92d1f72a96fd7d60c04480089db755bd8 SHA512 6897449fdefd07abe7714186b366fdf4505283f6747f8fa4d17044bc45da58eb36e69d89381527ccecb98e6c62c58bc6d4f558af41cbfc87b0221ae60ba71ff6
diff --git a/dev-python/fixtures/fixtures-4.1.0.ebuild b/dev-python/fixtures/fixtures-4.1.0.ebuild
new file mode 100644
index 000000000000..cf139f9da0ad
--- /dev/null
+++ b/dev-python/fixtures/fixtures-4.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pbr
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="
+ https://github.com/testing-cabal/fixtures/
+ https://pypi.org/project/fixtures/
+"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pbr-5.7.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest