summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-11 04:57:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-11 05:08:42 +0100
commitb4caf1bd4f77664167840ee3265fbcb70e62b0d1 (patch)
tree1f3421391fb47fda0ff94f3ff77107bf9132fa66 /dev-python/flaky
parentdev-python/packaging: Bump to 24.0 (diff)
downloadgentoo-b4caf1bd4f77664167840ee3265fbcb70e62b0d1.tar.gz
gentoo-b4caf1bd4f77664167840ee3265fbcb70e62b0d1.tar.bz2
gentoo-b4caf1bd4f77664167840ee3265fbcb70e62b0d1.zip
dev-python/flaky: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest1
-rw-r--r--dev-python/flaky/flaky-3.8.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
index 18849b18c5ea..f745c6bb2b5e 100644
--- a/dev-python/flaky/Manifest
+++ b/dev-python/flaky/Manifest
@@ -1 +1,2 @@
DIST flaky-3.7.0.tar.gz 29591 BLAKE2B 747fbda71055bba937abf3e7b97691c1f4b222f085069d1815d5a9eba669464d2ed5d6dcf1842ae82f1970de5cd5e3aea5b12476bfa2d9282549ad0cc62901e9 SHA512 b399f6e1323d6ca341803ac6f1eb318bf24dc37182d0b49b89bb81b9466dd36271ad6dbb9f48ea6fa4760ee631f1482bb6f49c64f4d4520c40634089c1b64f9a
+DIST flaky-3.8.0.tar.gz 25227 BLAKE2B 64ad4658058a2e6704b7493553ab3ffa0af7eccf1eaeb6eb5336f3ca5a25c1a187d641e49d983537d8ca0d7c48fdb944e18af788bb364c37ce1a0251cd36bdbb SHA512 3023bb136f9d91ffa149081f6483ae6bf85a4e689e0614b64d92880b3bdc312bfd2e6b1ddea43a33cd0a4a60daf3cedb1b2820bf25960adab21164d599d6fd44
diff --git a/dev-python/flaky/flaky-3.8.0.ebuild b/dev-python/flaky/flaky-3.8.0.ebuild
new file mode 100644
index 000000000000..7fbc776453fb
--- /dev/null
+++ b/dev-python/flaky/flaky-3.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin for pytest that automatically reruns flaky tests"
+HOMEPAGE="
+ https://github.com/box/flaky/
+ https://pypi.org/project/flaky/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ epytest -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ epytest -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ epytest --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}