summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-02 04:45:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-02 05:04:16 +0200
commitad2b569bdb78fd31be66ddb415cc12e448a0c372 (patch)
tree81dd14dbfbac40416edd88eddbe5594e6e8ae8cd /dev-python/flask
parentdev-python/werkzeug: Bump to 2.3.3 (diff)
downloadgentoo-ad2b569bdb78fd31be66ddb415cc12e448a0c372.tar.gz
gentoo-ad2b569bdb78fd31be66ddb415cc12e448a0c372.tar.bz2
gentoo-ad2b569bdb78fd31be66ddb415cc12e448a0c372.zip
dev-python/flask: Bump to 2.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/flask-2.3.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 663088692887..e9ea802ea145 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,2 +1,3 @@
DIST Flask-2.2.3.tar.gz 697599 BLAKE2B 619902202443567bc79111c15f19d0bea9e03b0fbd406e43c1f9d994975d9f529f8e58823d9f828bb8164bac6b6631ba1c00c3a1587b00afcb802082565248bc SHA512 de119d032b04eef80a99cee9658cac12f934e9a66d7dbb8304588d0c1320a8a19a8b0a78f69134a20ca26aa408db8686436c5c108ecc39e16b1eca1a3dea2d2c
DIST Flask-2.3.1.tar.gz 686211 BLAKE2B 83998bccde3c3b0abc413c27e4db7589ebbd82cad025ca2926e977bb267248164d529f9bd7b04483070a05fde3c6ce90ed2014ab510c689da0210d3c32af9364 SHA512 371d85a9af74484d7d77dab1747f9d331e797fa2bfeb3f2c72aa679091852efa505c56f37c197d7cb2f02a77a6e88ec2f1ee8efe35fc65d2c23afe5b24d6f4db
+DIST Flask-2.3.2.tar.gz 686251 BLAKE2B d81553b100e88ab79218422d6d39bb8b186f436c3729985504d1f54536b5e0f783509dcfbf0791890e7c03928131ddd4b8894db51f27e4075c50248ebd7846a2 SHA512 7917c3658a1dec77decad2dbc067a1ae602a66007573f1ff26527c214dede2c455ca5e6490159922fac967ceea99bd880cf929d05e21ed49b08abf501d96e8f8
diff --git a/dev-python/flask/flask-2.3.2.ebuild b/dev-python/flask/flask-2.3.2.ebuild
new file mode 100644
index 000000000000..1376fb6b9ea5
--- /dev/null
+++ b/dev-python/flask/flask-2.3.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="
+ https://palletsprojects.com/p/flask/
+ https://github.com/pallets/flask/
+ https://pypi.org/project/Flask/
+"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/blinker-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.3[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-2.3.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-3.6.0[${PYTHON_USEDEP}]
+ ' 3.9)
+"
+BDEPEND="
+ test? (
+ >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
+ !!dev-python/shiboken2
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs \
+ dev-python/sphinxcontrib-log_cabinet
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:httpbin
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}