summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-24 03:36:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-24 04:28:35 +0100
commit28c2849f79b5f0407265173e6078393d9ad3478f (patch)
treecbbefc5990a0983a8f47abf279852e3773d6966b /dev-python/frozenlist
parentdev-python/ruamel-yaml-clib: Remove old (diff)
downloadgentoo-28c2849f79b5f0407265173e6078393d9ad3478f.tar.gz
gentoo-28c2849f79b5f0407265173e6078393d9ad3478f.tar.bz2
gentoo-28c2849f79b5f0407265173e6078393d9ad3478f.zip
dev-python/frozenlist: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/frozenlist')
-rw-r--r--dev-python/frozenlist/Manifest1
-rw-r--r--dev-python/frozenlist/files/frozenlist-1.4.1-py313.patch13
-rw-r--r--dev-python/frozenlist/frozenlist-1.4.1.ebuild58
3 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/frozenlist/Manifest b/dev-python/frozenlist/Manifest
index d400ac05ae2c..3353670f87ae 100644
--- a/dev-python/frozenlist/Manifest
+++ b/dev-python/frozenlist/Manifest
@@ -1,2 +1 @@
-DIST frozenlist-1.4.1.gh.tar.gz 46357 BLAKE2B 44ee864cd6c7918634d2db85937d778a8526f3117e4d27e06267c979bda2228de5bacaa87d8e0339f7718d6c12325336025214b8d42bdcc744aac7adb63b736a SHA512 a82059fd7d16ec8e17cdf9d05eb128194fc3eed7c20ea4a3daf508a949e6c039fb5824794eac1ca768de11d883f55f46de45f5dcc5031f5cb31291b33df87023
DIST frozenlist-1.5.0.gh.tar.gz 46957 BLAKE2B 385b6439985256c5fd074582001a9c3d8ae82a0b839abfb3c2ff054ba3f5904d17740d7e49a17c96c571a0d8940933d292cc980c5a7bb30ae25fe88484ade185 SHA512 4486a3132038cf3eb29184bc27baab2f166078d25163da29114cb0595bd97c88848d88241cef39d42be9da5e2a99d14141d899bc5f268690c97bf38bf07c54dd
diff --git a/dev-python/frozenlist/files/frozenlist-1.4.1-py313.patch b/dev-python/frozenlist/files/frozenlist-1.4.1-py313.patch
deleted file mode 100644
index 5607461c9229..000000000000
--- a/dev-python/frozenlist/files/frozenlist-1.4.1-py313.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/tests/test_frozenlist.py b/tests/test_frozenlist.py
-index c0d91b5..b65a998 100644
---- a/tests/test_frozenlist.py
-+++ b/tests/test_frozenlist.py
-@@ -11,7 +11,7 @@ from frozenlist import FrozenList, PyFrozenList
- class FrozenListMixin:
- FrozenList = NotImplemented
-
-- SKIP_METHODS = {"__abstractmethods__", "__slots__"}
-+ SKIP_METHODS = {"__abstractmethods__", "__slots__", "__static_attributes__", "__firstlineno__"}
-
- def test___class_getitem__(self) -> None:
- assert self.FrozenList[str] is not None
diff --git a/dev-python/frozenlist/frozenlist-1.4.1.ebuild b/dev-python/frozenlist/frozenlist-1.4.1.ebuild
deleted file mode 100644
index e87bb49e59b7..000000000000
--- a/dev-python/frozenlist/frozenlist-1.4.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A list-like structure which implements collections.abc.MutableSequence"
-HOMEPAGE="
- https://pypi.org/project/frozenlist/
- https://github.com/aio-libs/frozenlist/
-"
-SRC_URI="
- https://github.com/aio-libs/frozenlist/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+native-extensions"
-
-BDEPEND="
- dev-python/expandvars[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- native-extensions? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/aio-libs/frozenlist/issues/588#issuecomment-2139078800
- "${FILESDIR}/${P}-py313.patch"
-)
-
-python_compile() {
- # pypy is not using the C extension
- if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
- local -x FROZENLIST_NO_EXTENSIONS=1
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- rm -rf frozenlist || die
- epytest -o addopts=
-}