summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-12-20 15:58:44 +0100
committerAlfredo Tupone <tupone@gentoo.org>2020-12-20 16:02:59 +0100
commitf00075ee23204f2c1766ebc0d38e21493a5a0d93 (patch)
tree6b1c51452aa1ce65fe8c44c1a185846cddbe2c64 /dev-python/funcy
parentdev-python/whatever: remove python as maintainer (diff)
downloadgentoo-f00075ee23204f2c1766ebc0d38e21493a5a0d93.tar.gz
gentoo-f00075ee23204f2c1766ebc0d38e21493a5a0d93.tar.bz2
gentoo-f00075ee23204f2c1766ebc0d38e21493a5a0d93.zip
dev-python/funcy: version bump and test added
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python/funcy')
-rw-r--r--dev-python/funcy/funcy-1.14-r1.ebuild31
-rw-r--r--dev-python/funcy/funcy-1.14.ebuild14
2 files changed, 32 insertions, 13 deletions
diff --git a/dev-python/funcy/funcy-1.14-r1.ebuild b/dev-python/funcy/funcy-1.14-r1.ebuild
new file mode 100644
index 000000000000..ac375d59f047
--- /dev/null
+++ b/dev-python/funcy/funcy-1.14-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+inherit distutils-r1
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="https://github.com/Suor/funcy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/whatever[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/funcy/funcy-1.14.ebuild b/dev-python/funcy/funcy-1.14.ebuild
index babc4c8350dd..dbae274d8803 100644
--- a/dev-python/funcy/funcy-1.14.ebuild
+++ b/dev-python/funcy/funcy-1.14.ebuild
@@ -13,19 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
+IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/whatever[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- distutils_install_for_testing --via-root
- pytest || die "Tests fail with ${EPYTHON}"
-}