summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-18 07:02:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-18 07:02:50 +0200
commit72fec465cac210aa1bbddb2cc59017e21141d89a (patch)
tree85445bfdd148e97a87b36e937a95d4b1e478cca0 /dev-python/furo
parentdev-python/scipy: Bump to 1.11.2 (diff)
downloadgentoo-72fec465cac210aa1bbddb2cc59017e21141d89a.tar.gz
gentoo-72fec465cac210aa1bbddb2cc59017e21141d89a.tar.bz2
gentoo-72fec465cac210aa1bbddb2cc59017e21141d89a.zip
dev-python/furo: Bump to 2023.8.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/furo')
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2023.8.17.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index 6e7c1e1c8ecc..249da06eadcb 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1,2 +1,3 @@
DIST furo-2023.5.20-py3-none-any.whl 326767 BLAKE2B cc8eb3816bf99039e1a312f9fed21538b0154ece228e351107df89f5770c382614efc7202bae742d28d2fc8fceabc8b748b2bfbe8a230aeb70f280b622d42c11 SHA512 1a97b37aa9ce55878f34e3276eebeb4b138bd9e397b6711469fed4523ab8dadcd91e77234a1eca20561276f6660410a31f48f34ae320c6772d1055699cdd7125
DIST furo-2023.7.26-py3-none-any.whl 326996 BLAKE2B 1da4cbbdcab66973e87228a423042f58499c95a0a4287ad4e5ff4b87a3ae27b31b68dfc1a267a1642b35455f420659755ef4791c519496799331379c806e8f2c SHA512 761c3b276d4db86dea0201c2f10e2958fe8ef784243687e6884406bdd11b009296158585ae865fc754c0b7674fe65cc2d6beaf3d997da672d2e4e319b1813fa1
+DIST furo-2023.8.17-py3-none-any.whl 327018 BLAKE2B 6a96b341b5f78581adb534154bbe56a6eaf5a21a8384597fc8e0f3106db0751619927dac536846fbe60ec0eb2f8769cb2efc0a65de36a00a3264abe90911400c SHA512 15165c5b212890264242d71ecb3ba43e1241683e3fd25bafb20f617b1e8fe59a3705fcbb9353d25c1318c9057407c7336e8a4c3a3aab0b18e7a0e6f24e9de850
diff --git a/dev-python/furo/furo-2023.8.17.ebuild b/dev-python/furo/furo-2023.8.17.ebuild
new file mode 100644
index 000000000000..0674aa0b847b
--- /dev/null
+++ b/dev-python/furo/furo-2023.8.17.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}