summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-11-10 09:47:14 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-17 19:44:59 +0100
commit92cd580f34fe372a717c77dcf92d41056ad5a870 (patch)
tree7472ef54667524ef764aa448b7f3f97f5b0576bc /dev-python/git-python/git-python-2.1.7.ebuild
parentapp-emulation/qemu-guest-agent: update HOMEPAGE (diff)
downloadgentoo-92cd580f34fe372a717c77dcf92d41056ad5a870.tar.gz
gentoo-92cd580f34fe372a717c77dcf92d41056ad5a870.tar.bz2
gentoo-92cd580f34fe372a717c77dcf92d41056ad5a870.zip
dev-python/git-python: Version bump to 2.1.7
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6161
Diffstat (limited to 'dev-python/git-python/git-python-2.1.7.ebuild')
-rw-r--r--dev-python/git-python/git-python-2.1.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/git-python/git-python-2.1.7.ebuild b/dev-python/git-python/git-python-2.1.7.ebuild
new file mode 100644
index 000000000000..bfa1722cf7ed
--- /dev/null
+++ b/dev-python/git-python/git-python-2.1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests only work with the GitPython repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb2-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"