summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-04 21:00:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 21:34:44 +0100
commit461dc14e8daff62472223dd0d0f537244c0e4b9e (patch)
treec04ec923a5bc526caf311f5aa2764adf396d9482 /dev-python/git-python
parentdev-python/gevent-websocket: Clean old up (diff)
downloadgentoo-461dc14e8daff62472223dd0d0f537244c0e4b9e.tar.gz
gentoo-461dc14e8daff62472223dd0d0f537244c0e4b9e.tar.bz2
gentoo-461dc14e8daff62472223dd0d0f537244c0e4b9e.zip
dev-python/git-python: Clean old up
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/Manifest2
-rw-r--r--dev-python/git-python/git-python-2.0.6.ebuild39
-rw-r--r--dev-python/git-python/git-python-2.1.5.ebuild37
3 files changed, 0 insertions, 78 deletions
diff --git a/dev-python/git-python/Manifest b/dev-python/git-python/Manifest
index 78a59118da67..ed5c973f752c 100644
--- a/dev-python/git-python/Manifest
+++ b/dev-python/git-python/Manifest
@@ -1,4 +1,2 @@
DIST GitPython-1.0.2.tar.gz 387615 BLAKE2B 50915f5ea98a47eeaf086f57ecc0847592721390b7eb38bc3d03e8258c74b4708cb3043142c160139d399337180300037db874d126abb5e54bbae855cd4e8039 SHA512 faff50d5272158f1d05d932e7827c05272f9a28772aabbcabd631b735bb4d8306d2861d13c327d02a4c554bd9a9902c473fb282318036405497dd8bf0fcc51a8
-DIST GitPython-2.0.6.tar.gz 406234 BLAKE2B cce0f958a5b741058880120175ef159cb93745f304ac646cad558780b559515148fa4aef10886df90f25e8bec6813360ad1e9695adeb143067ea37c6f57f4cc9 SHA512 97a64e715b2d78d58542de5adcf679aa73a64bae49b6c76c2ac56a8ffaa0f712f80b239a39408d79395bf4c3a6e5ca7c5ee21a166a8b4da597c898f92a5a123d
-DIST GitPython-2.1.5.tar.gz 420147 BLAKE2B 17d2ac4bb37d2145434b0dab76e458438455ea5e48992695da0e205e8012aef1b1036f6d35ab0ad7aceec8b2cb6a112427728fb4a282100d757029008f987519 SHA512 40350434edb12d3335ea6a9f0176df4eff0564c8c8388f6a9769d2ab9e46c708625849a079eaf4e1c5aa9eaf10d91f439097277d67e3c6b5e9659a88bfcdd4e2
DIST GitPython-2.1.7.tar.gz 426362 BLAKE2B 1d543b760bc0dbfdf95b120876c1f3454442a2e2bca69529229316fe5345129b852f4f6195066bc4750ac650083750c5ae0f842aeae871cba969aaf4c6563899 SHA512 3081fcf4944d49042fa95b55f1f0a152b405830fa592fbe546710798388e2bd7422bd2c62f5a7545f0820693fe1948ef31e1485d7b6bc2b37f2b807962e7da83
diff --git a/dev-python/git-python/git-python-2.0.6.ebuild b/dev-python/git-python/git-python-2.0.6.ebuild
deleted file mode 100644
index 3d1c453295f3..000000000000
--- a/dev-python/git-python/git-python-2.0.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="GitPython"
-MY_PV="${PV/_rc/.RC}"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.python.org/pypi/GitPython"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# Tests dont make sense without a git repo
-RESTRICT="test"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
-# is the correct entry for mock, however while RESTRICT="test"
-# there is little point in setting it since it is inactive
-S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/git-python/git-python-2.1.5.ebuild b/dev-python/git-python/git-python-2.1.5.ebuild
deleted file mode 100644
index 88367417a705..000000000000
--- a/dev-python/git-python/git-python-2.1.5.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="GitPython"
-MY_PV="${PV/_rc/.RC}"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.python.org/pypi/GitPython"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# Tests only work with the GitPython repo
-RESTRICT="test"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb2-2.0.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/ddt-1.1.0[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"