summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 14:14:22 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 14:23:51 +0100
commite949e59055b307e44f265ca0b2f86856f625d337 (patch)
tree8e6a0afafe4a7ee482797a9edfdce3b546a7abfb /dev-python/google-api-python-client
parentdev-python/mako: Bump to 1.2.0 (diff)
downloadgentoo-e949e59055b307e44f265ca0b2f86856f625d337.tar.gz
gentoo-e949e59055b307e44f265ca0b2f86856f625d337.tar.bz2
gentoo-e949e59055b307e44f265ca0b2f86856f625d337.zip
dev-python/google-api-python-client: Bump to 2.40.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.40.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 9bd163cb7605..7dcec388acd0 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.37.0.tar.gz 28868090 BLAKE2B 971fa3a873c902a34c100066a026ab6698d142a4875282d8be890b403a2edf1f00ea5a3dc4bcf90a30ad9dfb8aa5e1d5eb1b60e64a6718a6e054d49b7ff94afc SHA512 72543f78779403a5d16cfae8f84718d7a6dc08e9fcaa4e97d7a1f6e5ba6594b3a87762e229b94ccfc3a3ca196bbe0cd17c5fde949d101d5975b61cdc57a32622
DIST google-api-python-client-2.38.0.tar.gz 29194978 BLAKE2B 741cf925256f0bd648e68c339233cfc13a9eaa12e123e202eab64b8389bc493755838c3da8ca4e7f4ffeecacec783c41f37df1847edf0fb54387d58163c112fc SHA512 b93f1f946ebab226b9fdd9012c3ae70563197a895d9069f09c7eb8926cd8fe5567535d3677a6824f66720b9ed1f0a732f02be9440dc800a13cb7e335728a3ce8
+DIST google-api-python-client-2.40.0.tar.gz 29463380 BLAKE2B f70067d3afe614e34cf84480d7a653620b516689560033cf3ad72a963e53c76632d1254ed1ac5f492e9e4639a6d717889f0f84c283363892efa99ce1007bbb82 SHA512 ae345d46bcb13509dd631039079c3ef96899899c206bc19b47a873d8ebc9372e70f55bcada1c8ba9775d826dbe8b1fde96a8f496f5574bb15b3c73c7d848f189
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.40.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.40.0.ebuild
new file mode 100644
index 000000000000..8c829ff884d3
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.40.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}